summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-20 08:22:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-20 09:25:07 +0200
commit579a8364ce8d4b296622aa274c8ba34bcb01a29b (patch)
tree4f4a9db2ab83e3b79420ff5a20cc906fbbfa037e /dev-python/xarray
parentdev-python/pyls-spyder: Add python@ as co-maint. (diff)
downloadgentoo-579a8364ce8d4b296622aa274c8ba34bcb01a29b.tar.gz
gentoo-579a8364ce8d4b296622aa274c8ba34bcb01a29b.tar.bz2
gentoo-579a8364ce8d4b296622aa274c8ba34bcb01a29b.zip
dev-python/xarray: Bump to 0.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-0.18.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 1c107ceb35e7..84a62f80170f 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,2 +1,3 @@
DIST xarray-0.17.0.tar.gz 2055584 BLAKE2B afbd28032069e4b498c87abd34661dc96525cb581a08fcf68eeaca08468afb9b452650bce4d21cada0eb1cb75ad11b0565a6b965b11120d4bef4d4cd612fa91d SHA512 726d548519614936f4b6c6ded0375a35362b195a2c6b55a282d198cbb8a70fa7439377a88f253cf4f16c86582fc22c8a4700b9645516decf7edd3e980d9dda34
DIST xarray-0.18.1.tar.gz 2849935 BLAKE2B f4d510a049e67431737ba7f6a66fdd83061e6e5728ac6bfd3b9f104b24cc619cb1d0f05bbe6911e952c312ef229dbf1a68842b75dbb0ecf811fcc7d6e78569b0 SHA512 e1842d7bf06ee23716038fd58e7ae3a2014012cbc49394c9000272cb0498c1d333cbf3133b1d8fcdbddd524d44f6fa5fcc117c992d0ab1d3d0b9c4ddfc317847
+DIST xarray-0.18.2.tar.gz 2850065 BLAKE2B 16d8f5e10a7c9cb4247a3bc8f496f249d66235673e79d0707077e20b54a7d94a7b754fb00f44b876fa21273521f9e2e7d52183798ca33b8e62b30fbc57621c5a SHA512 3cfd6a3b77c48a73eb72e6c39db33aba266925df7ce9b8270231dd14032a717094073a2c3686b09fcff25313b548a452f9ed902211e254254389d15f025d8d0d
diff --git a/dev-python/xarray/xarray-0.18.2.ebuild b/dev-python/xarray/xarray-0.18.2.ebuild
new file mode 100644
index 000000000000..f797bf1c514c
--- /dev/null
+++ b/dev-python/xarray/xarray-0.18.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pkg_resources use in code
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.0[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}