summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-04-24 10:08:54 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-04-24 10:08:54 -0500
commit3a58ce987fecbf79396dcf0df5aafab3c52cab6c (patch)
tree9c333faba874614507cdf7d3354207b45b9594e4 /dev-python/wrapt/wrapt-1.10.8.ebuild
parentdev-python/websocket-client: remove version 0.32.0 (diff)
downloadgentoo-3a58ce987fecbf79396dcf0df5aafab3c52cab6c.tar.gz
gentoo-3a58ce987fecbf79396dcf0df5aafab3c52cab6c.tar.bz2
gentoo-3a58ce987fecbf79396dcf0df5aafab3c52cab6c.zip
dev-python/wrapt: add version 1.10.8
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/wrapt/wrapt-1.10.8.ebuild')
-rw-r--r--dev-python/wrapt/wrapt-1.10.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/wrapt/wrapt-1.10.8.ebuild b/dev-python/wrapt/wrapt-1.10.8.ebuild
new file mode 100644
index 000000000000..22a84a37fd84
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.10.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test -vv || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}