summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-06 19:34:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-06 19:44:38 +0300
commitb55a053a573c2dbfdf1f944d3629e7e9443d5b2d (patch)
tree82c2de528bd32fe6e630419ab542c5ff011cc6d9 /dev-python/whatthepatch
parentdev-python/numpy: Stabilize 1.24.2 ppc, #902071 (diff)
downloadgentoo-b55a053a573c2dbfdf1f944d3629e7e9443d5b2d.tar.gz
gentoo-b55a053a573c2dbfdf1f944d3629e7e9443d5b2d.tar.bz2
gentoo-b55a053a573c2dbfdf1f944d3629e7e9443d5b2d.zip
dev-python/whatthepatch: add 1.0.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest1
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.5.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index bcc8a300fb0e..5d60d2306937 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1 +1,2 @@
DIST whatthepatch-1.0.4.tar.gz 31063 BLAKE2B b3f66ca0783ae147ebf5d47aa155a23cfbc16fc19aaca9812b53b2a292543f64447e31b469645bfeffb8ab1b8a5ea7cebb9ebad5e9815d6a84a3b44068329448 SHA512 89705fa1ad4a797038b8c4cd30c7ca88b5b51474265bc157f45c244b258075cde587c6da16fabfaa2d6b90eee858ccf82c9f01ce8e44412a5eac504f95fb413b
+DIST whatthepatch-1.0.5.tar.gz 31850 BLAKE2B dfded6069aa70051fb5f399c9f4707969be4dfc1dee853cd8eb7f36e074c2b595eddbae3efd534321dbbcce7a6658ef9e9bc7675ef466e0a486d930d62761e1e SHA512 d87a36a608a15bcf6d28d26afee40161e26f17fa3b011056388f9850896577f913a91066de8b6071ea15b28fa05f8d00acb997b18483ea56218df4efb40109ab
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
new file mode 100644
index 000000000000..28281938d7b7
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest