summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 03:56:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 04:07:31 -0500
commit1105133b5fc8fb5614ddeb8ce19b19c47ec60ba9 (patch)
treee88b9ac6b5e87adb033c609b697e14bebfd67432 /dev-python/websockify
parentnet-firewall/nftables: revbump and patch to fix broken init script (diff)
downloadgentoo-1105133b5fc8fb5614ddeb8ce19b19c47ec60ba9.tar.gz
gentoo-1105133b5fc8fb5614ddeb8ce19b19c47ec60ba9.tar.bz2
gentoo-1105133b5fc8fb5614ddeb8ce19b19c47ec60ba9.zip
dev-python/websockify: liberty bup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/websockify')
-rw-r--r--dev-python/websockify/Manifest1
-rw-r--r--dev-python/websockify/websockify-0.7.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/websockify/Manifest b/dev-python/websockify/Manifest
index 7d7f912b8c88..c1a32afdd7f0 100644
--- a/dev-python/websockify/Manifest
+++ b/dev-python/websockify/Manifest
@@ -1 +1,2 @@
DIST websockify-0.6.0.zip 312980 SHA256 09fd696fc528fcc915e66d43006c4e73e4e009233724d45e365ada1f8b01251c SHA512 f7792b0140fd5170b39dd0cabdf176ea8db43b148068ec336ddf61b70e166f6f935411901675c13657efee7e9cdf4de78bc74b0e371ce91811098b16a11a2915 WHIRLPOOL 46199706a3c8988aa7aec6018ee5defe50a289023132f48bd5d48ed486e17317b7b3a1661e367b818e2cd9445eabd3672f25155f1117ddb641be9ecb9a54ca46
+DIST websockify-0.7.0.zip 316823 SHA256 a1d1f2a188f34622ae6349c2cd19067a9a6f89ff3d35e249559ffa9c75a9d05b SHA512 642a65239fbaa409127e18f637cbcc815af0e34b89573517c5fef0b2c5af71442ab2ff563ff0cc7fcfa41c87711b9d478c708ca4424bb08d288537f0f1b4b4ef WHIRLPOOL eb331874712f2ac98eff4749b7b2c76ee5976a5488b7db49006624a88a019a7813da2ccd45b68bc4930cb43e9b2c69b2a4cbd6fd3ab2ae02c2e9ea3dc131f4cd
diff --git a/dev-python/websockify/websockify-0.7.0.ebuild b/dev-python/websockify/websockify-0.7.0.ebuild
new file mode 100644
index 000000000000..cb45d81c6f51
--- /dev/null
+++ b/dev-python/websockify/websockify-0.7.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/kanaka/${PN}/archive/v${PV}.zip -> ${P}.zip"
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="https://github.com/kanaka/websockify"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"