summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 18:44:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 23:12:34 +0200
commit10c835ccc58e928e7efde52de114c92a035e5929 (patch)
tree157e0b95053250e2b4e53662b1f85d6c5968cdc4 /dev-python/watchdog
parentmedia-gfx/feh: 3.7.1 version bump (diff)
downloadgentoo-10c835ccc58e928e7efde52de114c92a035e5929.tar.gz
gentoo-10c835ccc58e928e7efde52de114c92a035e5929.tar.bz2
gentoo-10c835ccc58e928e7efde52de114c92a035e5929.zip
dev-python/watchdog: Bump to 2.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/watchdog')
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-2.1.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index ce1ac8885c48..9875e645dfdf 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -2,3 +2,4 @@ DIST watchdog-1.0.2.tar.gz 91796 BLAKE2B 001cbe82ff8aff0c4e56e4d1f02519047580ccc
DIST watchdog-2.0.3.tar.gz 95524 BLAKE2B 568e9d66efbfa98c19dab704681dbc48f869b59d51d7c7ff7ce1fd7465efcc6233f871e7f9276f2732692645491f2fd197a639b17e9a3d8abb76d0148a934796 SHA512 e1c506e4ead8c3ee8d19e456b67623f3a1823007be6c1fad0d76c697205696183e7bd15e46c21bf61abce6dd16d267e55da8986633eeee337d10c609318fb958
DIST watchdog-2.1.1.tar.gz 96703 BLAKE2B cbcaff41de6111a3c9c2ff00b7c0a9ce1a769bb2b0f8e2af841a0783dd7f3a55f46003863b05eb983531211743fd112a6e63944193e10e8dd296523a1da27d59 SHA512 5b9eb75bc7b8642a8246f426a992265bbe2e5d82a3fcdd543289db7734701bdca1a868b02edfdc26ea239a89d80dd5322e410b949e419c66bdcc0645241d826b
DIST watchdog-2.1.2.tar.gz 97407 BLAKE2B a847089409537391287a146670864c7721344ba8a6378c89483e9e08abe3f61690bfca48016f628ab0e6b0ff317679db3c72e27594e049ea03334dd20c305008 SHA512 2a127faffebb35f0b14d578570a4c5a7c27d6bd38042e34ea50f4b654be1ca07b193dfa72dfe25442d3e6da746f1cfbdda71c38be1386cc5a3e69204843c16f1
+DIST watchdog-2.1.4.tar.gz 98695 BLAKE2B 2a15b362c6e776146df4738096fe0cd8ec49894c6b767e86ed5749c2f97447fb890f172ec989a17140594070eefa1fa2b40275aff5ba9d212f77a059ac3ead25 SHA512 88bed725c045f59091902a1fe4673036a679d263c71269e36125df2a4c851864bddee0cf4f8c3f20bfc2d5f735804b7c7b1ff07a3d89d8649bfa16d3e7e1fe21
diff --git a/dev-python/watchdog/watchdog-2.1.4.ebuild b/dev-python/watchdog/watchdog-2.1.4.ebuild
new file mode 100644
index 000000000000..7b9fe168c229
--- /dev/null
+++ b/dev-python/watchdog/watchdog-2.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ default
+}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/test_inotify_buffer.py::test_move_internal_batch
+ )
+
+ epytest -p no:django ${deselect[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}