summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-08-09 18:43:07 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-08-09 18:43:07 +0700
commit00c48cefd6cd104caf3d3c60f038704b3ffb1bca (patch)
treed4cd23ccf8583d756ca1423f6eec47ba236a227c /dev-python/watchdog
parentdev-python/pathtools: python3_5 added (diff)
downloadgentoo-00c48cefd6cd104caf3d3c60f038704b3ffb1bca.tar.gz
gentoo-00c48cefd6cd104caf3d3c60f038704b3ffb1bca.tar.bz2
gentoo-00c48cefd6cd104caf3d3c60f038704b3ffb1bca.zip
dev-python/watchdog: python3_5 added
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/watchdog')
-rw-r--r--dev-python/watchdog/watchdog-0.8.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/watchdog/watchdog-0.8.3-r1.ebuild b/dev-python/watchdog/watchdog-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..d678faa8973e
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}