summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-04-03 22:54:52 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-04-03 22:54:52 +0700
commitd75c1d0cac4edc9a8bd93a9ade45a8aeaae14a41 (patch)
tree1adefc028e457eecb21b705953510823dbd32ead /dev-python/vpython
parentdev-lisp/sbcl: remove old versions (diff)
downloadgentoo-d75c1d0cac4edc9a8bd93a9ade45a8aeaae14a41.tar.gz
gentoo-d75c1d0cac4edc9a8bd93a9ade45a8aeaae14a41.tar.bz2
gentoo-d75c1d0cac4edc9a8bd93a9ade45a8aeaae14a41.zip
dev-python/vpython: bump to 7.6.5
Closes: https://bugs.gentoo.org/928503 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/vpython')
-rw-r--r--dev-python/vpython/Manifest1
-rw-r--r--dev-python/vpython/vpython-7.6.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/vpython/Manifest b/dev-python/vpython/Manifest
index cd978844f63f..31bbeaa0eb44 100644
--- a/dev-python/vpython/Manifest
+++ b/dev-python/vpython/Manifest
@@ -1 +1,2 @@
DIST vpython-7.6.4.tar.gz 4504204 BLAKE2B 941eff8f9e5ca636001785b21e914194a4a84b910b8e329a45e2c0f0857c46c7658f9d0db128b524a0b760aa04d523617b473e73438d88ffb13e6ffdcc4419fe SHA512 997a6e351e0ae86938e557029a4888a508cdd7ae6aaa25dc578a772a5bbee857edc7c4414d48a9a6a48eff1e0ba435cfd24b98c47a6286cf0bb43e48db2b57c9
+DIST vpython-7.6.5.tar.gz 4533807 BLAKE2B c9eb7c243aba1e9147f7ec6529ba217ffa4acd2956c84bdb1da11e361653ced4f937545343d2daac01cd1063124f9e4ca55d9abff66c42c64d3f512e0f5e83ac SHA512 75836d113eaaf38f576ed148e33c955751da30198a40e4afeee3405209a94d70ca80166609782f079158ce430125394986750248206805bc28841820c0d868d6
diff --git a/dev-python/vpython/vpython-7.6.5.ebuild b/dev-python/vpython/vpython-7.6.5.ebuild
new file mode 100644
index 000000000000..199751729c52
--- /dev/null
+++ b/dev-python/vpython/vpython-7.6.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="https://www.vpython.org/ https://pypi.org/project/vpython/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/autobahn-18.8.2[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-proxy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest