summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-20 21:54:19 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-20 21:54:19 +0200
commitde41b72733be36f969c75a8d8d4e0e7f46cc2ed9 (patch)
treee13303d162bfe89913a14e5036005f9ddeecaa92 /dev-python/visitor
parentdev-python/dominate: add PyPy{,3} (diff)
downloadgentoo-de41b72733be36f969c75a8d8d4e0e7f46cc2ed9.tar.gz
gentoo-de41b72733be36f969c75a8d8d4e0e7f46cc2ed9.tar.bz2
gentoo-de41b72733be36f969c75a8d8d4e0e7f46cc2ed9.zip
dev-python/visitor: support PyPy{,3}
Remove DEPEND on pytest-runner Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/visitor')
-rw-r--r--dev-python/visitor/visitor-0.1.3.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/visitor/visitor-0.1.3.ebuild b/dev-python/visitor/visitor-0.1.3.ebuild
index a29aadde8829..b6ff311f6c16 100644
--- a/dev-python/visitor/visitor-0.1.3.ebuild
+++ b/dev-python/visitor/visitor-0.1.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
@@ -20,7 +20,6 @@ IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/pytest-runner[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"