summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-03 17:24:13 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-03 17:24:42 +0200
commit2dfbe9873886fc03621c69b429195fef29532486 (patch)
tree974409c0d63a2c5cbe423f9e13e62bb2fa48c70c /dev-python/vertex/vertex-0.3.1-r1.ebuild
parentsys-devel/gdb: 7.10 hangs on CPU, mask it for now (diff)
downloadgentoo-2dfbe9873886fc03621c69b429195fef29532486.tar.gz
gentoo-2dfbe9873886fc03621c69b429195fef29532486.tar.bz2
gentoo-2dfbe9873886fc03621c69b429195fef29532486.zip
dev-python/vertex: add libressl support
Diffstat (limited to 'dev-python/vertex/vertex-0.3.1-r1.ebuild')
-rw-r--r--dev-python/vertex/vertex-0.3.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/vertex/vertex-0.3.1-r1.ebuild b/dev-python/vertex/vertex-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..c790604505c3
--- /dev/null
+++ b/dev-python/vertex/vertex-0.3.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex https://pypi.python.org/pypi/Vertex"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ >=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc NAME.txt
+}