summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-07 18:32:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-07 18:49:16 +0200
commit292ada82d128d248699b777ed6a05d9abc5f744d (patch)
treed31377c2a8612bbe787692b989e7f91bdb2253d0 /dev-python/urllib3
parentdev-python/python-ironicclient: add 4.10.0 (diff)
downloadgentoo-292ada82d128d248699b777ed6a05d9abc5f744d.tar.gz
gentoo-292ada82d128d248699b777ed6a05d9abc5f744d.tar.bz2
gentoo-292ada82d128d248699b777ed6a05d9abc5f744d.zip
dev-python/urllib3: add 1.26.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-1.26.8.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 6dc700bc75f4..8a6f8142e297 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1 +1,2 @@
DIST urllib3-1.26.7.tar.gz 291350 BLAKE2B 5a95ea4df2e5a66ac7f3059b5453e122ae0e40531a23cb743e5a9574778a370d0cee3cb63fe6b29483b27c4a6ec498266ec5a0434db882ce0a79fb8d8400e08d SHA512 6f5a5e6dd5ff99950fcc051495e0a698153b57e20b6c83d869b54c7fece9616909bcf2fe99efc40815f8722996ad93e430bf765ce5c629b912690c286014b86f
+DIST urllib3-1.26.8.tar.gz 294280 BLAKE2B 401801b16c0c5152cabdfe3317cc53bc79a5aec103cc53a22189dcefcf0d022a05f6afac0bd99274a2fe48b6e86da8eb544b78e4c3a1534f000a9756ff15ccd9 SHA512 bcb56faa5dbe6019f70b63c076e118ec5f89e2d0c25f0e415d9db079532c98ced7e636cec5bf26210d4b0a08bb7b5b7a33a5c8648ccdaad129eea3a212a53bc5
diff --git a/dev-python/urllib3/urllib3-1.26.8.ebuild b/dev-python/urllib3/urllib3-1.26.8.ebuild
new file mode 100644
index 000000000000..01b718ef8c5b
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.26.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/urllib3/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli test"
+RESTRICT="!test? ( test )"
+
+# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
+# dependencies. Do not add them to RDEPEND. They should be unnecessary with
+# modern versions of python (>= 3.2).
+RDEPEND="
+ >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
+ brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlicffi[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " python3_{8..10})
+ )
+"
+
+python_test() {
+ local -x CI=1
+ # FIXME: get tornado ported
+ # please keep in sync with BDEPEND!
+ if ! has "${EPYTHON}" python3.{8..10}; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # TODO?
+ test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_3::test_verified
+ test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
+ )
+
+ epytest
+}