summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-27 05:56:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-27 06:40:41 +0200
commitb6171cb034c4b6a4eb7ec2bd7bc4ee95dded1c2c (patch)
tree84abdd22f5bde5efb604058e11bd05d1e5052877 /dev-python/unidiff
parentdev-python/marshmallow: Bump to 3.17.0 (diff)
downloadgentoo-b6171cb034c4b6a4eb7ec2bd7bc4ee95dded1c2c.tar.gz
gentoo-b6171cb034c4b6a4eb7ec2bd7bc4ee95dded1c2c.tar.bz2
gentoo-b6171cb034c4b6a4eb7ec2bd7bc4ee95dded1c2c.zip
dev-python/unidiff: Bump to 0.7.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unidiff')
-rw-r--r--dev-python/unidiff/Manifest1
-rw-r--r--dev-python/unidiff/unidiff-0.7.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/unidiff/Manifest b/dev-python/unidiff/Manifest
index a6c04261fd1b..320ea2cc930e 100644
--- a/dev-python/unidiff/Manifest
+++ b/dev-python/unidiff/Manifest
@@ -1 +1,2 @@
+DIST python-unidiff-0.7.4.gh.tar.gz 17582 BLAKE2B 9b674d5b1bc434464c5b7b08b4b6527e1394633abcc6211b9f459fde545fef1c6418ad84dbe9cf7a3a308deeb2221749f50f25458306046f2930d0fcc3af9526 SHA512 b8e1d8165efcc5788707432c3c3236d97ec86ae577ff3dd7ec405809dbaef3153a835572844f7ef2a4d5d2c9b60dee586717e4cf0acf4db8049ab7c5af178a07
DIST unidiff-0.7.3.tar.gz 19897 BLAKE2B bc29b912855955de08fdbc186bdf9edf63a0a622262f36a54160f2c61e6604a40d093d43261101864c209e4d2cd5c1db0e48d0dd76174b02a71f89199e00e31d SHA512 451bc765532329c0963961afd15e061e3bcbd85a16cb799310ae0fd34b534f6222514ed4825f90c5ae9ea1b3b0e11a8e169b7991ba9ed82c33325ccb3b10a3b0
diff --git a/dev-python/unidiff/unidiff-0.7.4.ebuild b/dev-python/unidiff/unidiff-0.7.4.ebuild
new file mode 100644
index 000000000000..a7d91e8e1903
--- /dev/null
+++ b/dev-python/unidiff/unidiff-0.7.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+# TODO: rename when the old version is gone?
+MY_P=python-${P}
+DESCRIPTION="Unified diff parsing/metadata extraction library"
+HOMEPAGE="
+ https://github.com/matiasb/python-unidiff/
+ https://pypi.org/project/unidiff/
+"
+SRC_URI="
+ https://github.com/matiasb/python-unidiff/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest