summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-05-08 10:27:23 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-05-08 13:34:14 -0700
commita2e505aa62bbfd8128543b6a19f47a3a705c7a6f (patch)
treee24f9884da31bdcfccd213356dca202d7ff6f38d /dev-python/txrequests/txrequests-0.9.6.ebuild
parentdev-python/sqlalchemy-migrate: Version bump, adds python-3.8 (diff)
downloadgentoo-a2e505aa62bbfd8128543b6a19f47a3a705c7a6f.tar.gz
gentoo-a2e505aa62bbfd8128543b6a19f47a3a705c7a6f.tar.bz2
gentoo-a2e505aa62bbfd8128543b6a19f47a3a705c7a6f.zip
dev-python/txrequests: Version bump, adds python-3.8
metadata.xml: take maintainership Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/txrequests/txrequests-0.9.6.ebuild')
-rw-r--r--dev-python/txrequests/txrequests-0.9.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/txrequests/txrequests-0.9.6.ebuild b/dev-python/txrequests/txrequests-0.9.6.ebuild
new file mode 100644
index 000000000000..c3e3311783d6
--- /dev/null
+++ b/dev-python/txrequests/txrequests-0.9.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8})
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/tardyp/txrequests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-1.2.0[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"