summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-09 09:49:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-09 10:08:00 +0100
commit32aa49f114bda811471c80b8cc5a9753b07a3abc (patch)
tree4d198f38e6619ff892496be1649d57735027641f /dev-python/treq
parentapp-admin/awscli: Bump to 1.22.51 (diff)
downloadgentoo-32aa49f114bda811471c80b8cc5a9753b07a3abc.tar.gz
gentoo-32aa49f114bda811471c80b8cc5a9753b07a3abc.tar.bz2
gentoo-32aa49f114bda811471c80b8cc5a9753b07a3abc.zip
dev-python/treq: Bump to 22.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/treq')
-rw-r--r--dev-python/treq/Manifest1
-rw-r--r--dev-python/treq/treq-22.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/treq/Manifest b/dev-python/treq/Manifest
index fb7fdf5fda1a..507bec574157 100644
--- a/dev-python/treq/Manifest
+++ b/dev-python/treq/Manifest
@@ -1 +1,2 @@
DIST treq-22.1.0.tar.gz 72634 BLAKE2B e59271bbd53124fa6c01cb9fba03d83ba8cdfc1b2be065c649e26dbcd0202473b59fc1762ce02d5d016d1ac5a6a848568b248c316d7ecde8e3f3521cb213d532 SHA512 6c9a49bc4c9e73365275bf841a5a31873c092e33c4978571caae3601d02e9b8d161dcf684c40ccd297d8a8c4dafe62eddb7872a86513598260fe38c98c7c44f5
+DIST treq-22.2.0.tar.gz 72922 BLAKE2B ab4637c801e5e777f81f6e6a6e12e36ef47e052a4103eb70bf4e10d3fb44b60f144f32734625b4babb375acc96e3cad1895634d3d2fc08ac3095769180e65328 SHA512 465a02481a51ac246ac85f561f2e7a59d97aeeda9f0953dd83678ff836802a187a6aedcce830a9e3095a9c72227bd06113610c3be0967f1362a645a31278bde0
diff --git a/dev-python/treq/treq-22.2.0.ebuild b/dev-python/treq/treq-22.2.0.ebuild
new file mode 100644
index 000000000000..e5e1a9824053
--- /dev/null
+++ b/dev-python/treq/treq-22.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A requests-like API built on top of twisted.web's Agent"
+HOMEPAGE="https://github.com/twisted/treq https://pypi.org/project/treq/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/hyperlink-21.0.0[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[crypt,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # fix relative path for docs generation
+ sed -e "s@('..')@('../src')@" -i docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial treq || die "Tests failed with ${EPYTHON}"
+}