summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-16 07:17:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-16 07:17:25 +0200
commitf2bf8bbc527800d51e82a765e8bcd5c5e0ace288 (patch)
treefc06d847f21e3bb7c5c21e19b1fe53b83e1621f3 /dev-python/tornado
parentapp-portage/mgorny-dev-scripts: Bump to v39 (diff)
downloadgentoo-f2bf8bbc527800d51e82a765e8bcd5c5e0ace288.tar.gz
gentoo-f2bf8bbc527800d51e82a765e8bcd5c5e0ace288.tar.bz2
gentoo-f2bf8bbc527800d51e82a765e8bcd5c5e0ace288.zip
dev-python/tornado: Bump to 6.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest1
-rw-r--r--dev-python/tornado/tornado-6.3.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 5ef7047ba7dc..46c58ade02bf 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,3 +1,4 @@
DIST tornado-6.2.tar.gz 504849 BLAKE2B 18fee464e043e20dcdd5677bc3a72949140a64ce353e09a21242fcade6d8b668517553c649d65e892d9c3fabacea96903d4e42b70676a62759900abc8f4a202f SHA512 157cbeee21bef29ac68b319329e7fc57db4c68dbb5a245e2171b7a28427ebbfe16b745e3bdbdec5912caae5eaa60c3cbbf8830c9c76fec5ffdf025e234468517
DIST tornado-6.3.1.tar.gz 508547 BLAKE2B ed7d9085f75291d341574c610b23a9a24468238988e7bd726be6da4ed8cd5588c1df5e11a154f3c9843931d210198d3bd57d3999b4bdcdf13b3b78afec04df36 SHA512 e6b33d017448060d29e718cb4ed4f852f3f1a970ef6149fcf88900cf7a7f008b737cfdad3c217a6c43a5c7176aee0adb72c3c0055b6b3faac49acd34c3b74b90
+DIST tornado-6.3.2.tar.gz 508776 BLAKE2B 10cea881365ab72290ac9bc240dc7fa4e77511be1aa9d005e84fff1c494888d204935f5bf5101d102cc6e8f0995d41c0cc257e372d740f2aa47dc904032c434d SHA512 cd4be43672dcf0814536ad1b2b1dde045f25494a9f70facf0dbae5d3a71b112d0dbca235916948982922975d0d4c58efff880c0b432db382f58f25d65ef18c92
DIST tornado-6.3.tar.gz 507992 BLAKE2B a894fbb62e4246be82b09856977758e8e55886b77917a4a23a6411a58b2b85ae1ae9113e70cc00bf0b0775566d0bda237ab3ba91ff18012c7c72f24dff587a9e SHA512 f25bbf1e489bb53ba5ed502a9241b3629a66a8bee3ba54d8bd96946e478ea06dfdf70e6f937da25c8240cb16cc5c9ff3011415503c7d03e2b1eeb2f7567d8209
diff --git a/dev-python/tornado/tornado-6.3.2.ebuild b/dev-python/tornado/tornado-6.3.2.ebuild
new file mode 100644
index 000000000000..ccbe90d68266
--- /dev/null
+++ b/dev-python/tornado/tornado-6.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+src_prepare() {
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}