summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-27 04:41:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-27 04:41:01 +0100
commit92f84d3cdcefa5f29e56649754ba1649c0296104 (patch)
tree06adc68c3fabaffe228f24f587649a5aaea4dba6 /dev-python/tornado
parentapp-admin/awscli: Bump to 1.32.8 (diff)
downloadgentoo-92f84d3cdcefa5f29e56649754ba1649c0296104.tar.gz
gentoo-92f84d3cdcefa5f29e56649754ba1649c0296104.tar.bz2
gentoo-92f84d3cdcefa5f29e56649754ba1649c0296104.zip
dev-python/tornado: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest1
-rw-r--r--dev-python/tornado/tornado-6.3.3.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 7e493f18839f..17479fd3986d 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,2 +1 @@
-DIST tornado-6.3.3.tar.gz 509872 BLAKE2B 575928b932a912515730b23ab712d6107b27ccb37c703be722768442093d47623e27ed31f60816c4031cd04354182796275619f27896d970e350dbb51a341b0a SHA512 3d4b0f933f09b8f8d5de5f93662de73d97a0ed98f5b56e0810d803d537092c74e89315dc9aaa0af85f91e18eca64cf429f6f73bce29523ce56738398fa24a597
DIST tornado-6.4.tar.gz 498845 BLAKE2B ebcdcfa93490107addfe69f722e2d85058a92fc366b09a4794a4d6e0a93040ef9791095a5a94d21937d4e88dea09521644cf92d0f2c7e98238dc58e6b864a009 SHA512 c063509d4c385e410c63cccdc1e9c66aa2bb739473667ede56cb801b7379b910c8059dec831d609109f3076222b588b257afd960dffa422d7a872867dcdda7c7
diff --git a/dev-python/tornado/tornado-6.3.3.ebuild b/dev-python/tornado/tornado-6.3.3.ebuild
deleted file mode 100644
index 26b9f51602fa..000000000000
--- a/dev-python/tornado/tornado-6.3.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="
- https://www.tornadoweb.org/
- https://github.com/tornadoweb/tornado/
- https://pypi.org/project/tornado/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep '
- >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.3.2-test-timeout-increase.patch
- "${FILESDIR}"/${PN}-6.3.2-ignore-deprecationwarning.patch
-)
-
-src_prepare() {
- # network-sandbox? ipv6?
- sed -i -e 's:test_localhost:_&:' \
- tornado/test/netutil_test.py || die
- # regressions with py3.12, not important enough to block us
- sed -e 's:test_chunked(:_&:' \
- -e 's:test_gzip:_&:' \
- -e 's:test_header_callback:_&:' \
- -i tornado/test/{curl_,simple_,}httpclient_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x ASYNC_TEST_TIMEOUT=60
- # Avoid time-sensitive tests
- # https://github.com/tornadoweb/tornado/blob/10974e6ebee80a26a2a65bb9bd715cf858fafde5/tornado/test/util.py#L19
- local -x TRAVIS=1
- local -x NO_NETWORK=1
-
- cd "${T}" || die
- "${EPYTHON}" -m tornado.test.runtests --verbose ||
- die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r demos/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}