summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-29 11:30:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:12:00 +0300
commit9e6aa49462f5ab2c033202b5f8f47ff6dca67294 (patch)
treed32849bddacb5f408c94f72d2fdd0a419b800f3d /dev-python/tifffile/tifffile-2022.7.28.ebuild
parentdev-python/iminuit: add 2.15.1 (diff)
downloadgentoo-9e6aa49462f5ab2c033202b5f8f47ff6dca67294.tar.gz
gentoo-9e6aa49462f5ab2c033202b5f8f47ff6dca67294.tar.bz2
gentoo-9e6aa49462f5ab2c033202b5f8f47ff6dca67294.zip
dev-python/tifffile: add 2022.7.28
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tifffile/tifffile-2022.7.28.ebuild')
-rw-r--r--dev-python/tifffile/tifffile-2022.7.28.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tifffile/tifffile-2022.7.28.ebuild b/dev-python/tifffile/tifffile-2022.7.28.ebuild
new file mode 100644
index 000000000000..c7b39355f0d6
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.7.28.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)