summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:45:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:55:52 +0200
commitef0404fda2c61bebb1603da478bfbd3b90478efa (patch)
treefb030797ad051405a8091d57fbe310a41071e041 /dev-python/tempora
parentdev-python/taskflow: Remove redundant versions (diff)
downloadgentoo-ef0404fda2c61bebb1603da478bfbd3b90478efa.tar.gz
gentoo-ef0404fda2c61bebb1603da478bfbd3b90478efa.tar.bz2
gentoo-ef0404fda2c61bebb1603da478bfbd3b90478efa.zip
dev-python/tempora: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempora')
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-1.14.1-r1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index 4195a5472f09..7db945c48b36 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1,2 +1 @@
-DIST tempora-1.14.1.tar.gz 19383 BLAKE2B f65896391e839c3da43bb42715459b9ab870a724722bfc83c129f18032e731d69b2d12635a519226ef4ce99e77a3418e7e1a05a116a80c222b4e8138f9966f9e SHA512 4ecd5430d4d90959b0985908a1e4f239a56ce0026cd315ef6b8c204b645caccb135db76bb2ca9cb95bc65bdf337b61e7c31514eb9c85036771469b6a058edfbb
DIST tempora-3.0.0.tar.gz 21500 BLAKE2B 7bf241d5ab60c78c0ea56df6b28e33504200eb5427cdffaf9d5f34da202c3ba4550fa4dcc48874ee870345fa5a10f2b874687fe7de2bbe049b1c14d05161b0e0 SHA512 2d397c1d17bb4c502817ad0278090137fb8ca00273c63a7336200ed7e621a99cd5c954cdc2da00d06eba34ed4f079429f5ddc68b928cc83feacb2335f995e1b7
diff --git a/dev-python/tempora/tempora-1.14.1-r1.ebuild b/dev-python/tempora/tempora-1.14.1-r1.ebuild
deleted file mode 100644
index 34ec22695b19..000000000000
--- a/dev-python/tempora/tempora-1.14.1-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Objects and routines pertaining to date and time"
-HOMEPAGE="https://github.com/jaraco/tempora"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-3.2" \
- ">=dev-python/rst-linker-1.9"
-
-python_prepare_all() {
- # avoid a setuptools_scm dependency
- sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
- sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
- setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}