summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-03 08:26:57 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-03 09:37:32 +0200
commitbc8fe70d53f045b283ab1e2706eca66f68b91d39 (patch)
treeda40fea5bb62bd5c885506a8952381abb0f05917 /dev-python/subunit
parentdev-python/verboselogs: Clean old versions up (diff)
downloadgentoo-bc8fe70d53f045b283ab1e2706eca66f68b91d39.tar.gz
gentoo-bc8fe70d53f045b283ab1e2706eca66f68b91d39.tar.bz2
gentoo-bc8fe70d53f045b283ab1e2706eca66f68b91d39.zip
dev-python/subunit: Clean old versions up
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/Manifest1
-rw-r--r--dev-python/subunit/subunit-1.1.0.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/subunit/Manifest b/dev-python/subunit/Manifest
index 8b829ad899c1..5221657f749b 100644
--- a/dev-python/subunit/Manifest
+++ b/dev-python/subunit/Manifest
@@ -1,2 +1 @@
-DIST subunit-1.1.0.tar.gz 441946 SHA256 4869a5bec96b7b4e760d053f842d80548008740cda1a7efbb9053063ee818a51 SHA512 11aaa8f2ae04232623fbfb7b9561aa15bddbc55201a3a16eea1319a076de3417977590c57bb7ab0bbd86b321b203241ba5ea8050932759aeb3f3ed71b723a98b WHIRLPOOL 2705fcb98d0b67b5d2cddff87095a9b65782467f3e9b84f956ac29c85c2995881dcd63468a144277fb76b7adfdbbb2ecdc36eae8413886a72028e3565edbdf47
DIST subunit-1.2.0.tar.gz 460532 SHA256 27f0561297a7d56d85a8f5491f47e44303d0bb1d99c5627486774ea1bcb3d5c3 SHA512 f6559fd771ad0732985230d11a9a8326ef35c817b62d1f50dc332f0032f7b08559a46d2534983b7d3964e45682ac49b3e348581ee0983861390abcd4ec20459c WHIRLPOOL c30b4a2c9ab17f49f87e206fe5833ae564452b99af447f8c4cbf969b2f2dd96e482fc583e84264be815b051b1bd12e6c132cd779c88d0d68da53956fef0b25b7
diff --git a/dev-python/subunit/subunit-1.1.0.ebuild b/dev-python/subunit/subunit-1.1.0.ebuild
deleted file mode 100644
index fcd0955cc055..000000000000
--- a/dev-python/subunit/subunit-1.1.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
-
-inherit distutils-r1 eutils multilib-minimal
-
-DESCRIPTION="A streaming protocol for test results"
-HOMEPAGE="https://launchpad.net/subunit https://pypi.python.org/pypi/python-subunit"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
-IUSE="static-libs test"
-
-RDEPEND="
- >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]
- dev-lang/perl:=
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
- >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- test? ( dev-python/testscenarios[${PYTHON_USEDEP}] )"
-
-# Take out rogue & trivial failing tests that exit the suite before it even gets started
-# The removed class in fact works fine in py3 and fails with py2.7 & pupu
-# The setu to restrict this patch is just those 2 is not worth it.
-PATCHES=( "${FILESDIR}"/1.0.0-tests.patch )
-
-src_prepare() {
- sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
-
- # Install perl modules in vendor_perl, bug 534654.
- export INSTALLDIRS=vendor
-
- # needed for perl modules
- distutils-r1_src_prepare
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-multilib_src_compile() {
- default
- multilib_is_native_abi && distutils-r1_src_compile
-}
-
-python_test() {
- local -x PATH="${PWD}/shell/share:${PATH}"
- local -x PYTHONPATH=python
- # Following tests are known to fail in py2.7 & pypy. They pass under py3.
- # DO NOT re-file
- # test_add_error test_add_error_details test_add_expected_failure
- # test_add_expected_failure_details test_add_failure test_add_failure
- # https://bugs.launchpad.net/subunit/+bug/1436686
-
- "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
-}
-
-multilib_src_test() {
- multilib_is_native_abi && distutils-r1_src_test
-}
-
-multilib_src_install() {
- local targets=(
- install-include_subunitHEADERS
- install-pcdataDATA
- install-exec-local
- install-libLTLIBRARIES
- )
- emake DESTDIR="${D}" "${targets[@]}"
-
- multilib_is_native_abi && distutils-r1_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
- prune_libtool_files
-}