summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-22 21:41:14 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:19:41 +0000
commitd758fba898b97ecc47fcfdc0bb3b29fb93309057 (patch)
tree91ba3d13f70ce1258cae7c2cf9408ac10dff0fda /dev-python/stestr
parentdev-python/oslotest: Mark ALLARCHES (diff)
downloadgentoo-d758fba898b97ecc47fcfdc0bb3b29fb93309057.tar.gz
gentoo-d758fba898b97ecc47fcfdc0bb3b29fb93309057.tar.bz2
gentoo-d758fba898b97ecc47fcfdc0bb3b29fb93309057.zip
dev-python/stestr: Port to python 3.9
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/stestr')
-rw-r--r--dev-python/stestr/stestr-2.1.0-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/stestr/stestr-2.1.0-r1.ebuild b/dev-python/stestr/stestr-2.1.0-r1.ebuild
index 420e4cdb2d60..17c04bb67e58 100644
--- a/dev-python/stestr/stestr-2.1.0-r1.ebuild
+++ b/dev-python/stestr/stestr-2.1.0-r1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="A parallel Python test runner built around subunit"
@@ -14,10 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.18.0[${PYTHON_USEDEP}]