summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-30 14:51:06 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-08 12:04:06 +0300
commitf8586d42834ca857828498488d3e0aa78029c684 (patch)
tree9181a071178882bb406e61069b65e33a4605ddf9 /dev-python/spyder-notebook
parentgames-util/pyfa: cleanup old version (diff)
downloadgentoo-f8586d42834ca857828498488d3e0aa78029c684.tar.gz
gentoo-f8586d42834ca857828498488d3e0aa78029c684.tar.bz2
gentoo-f8586d42834ca857828498488d3e0aa78029c684.zip
dev-python/spyder-notebook: version bump to 0.3.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/16910 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index 0bf8e544a0c5..c1819565db81 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1 +1,2 @@
DIST spyder-notebook-0.2.3.tar.gz 3692690 BLAKE2B 74fa380233155ef411f1bc6018111d94eb03cdf4d4d3b75937b4e63047320bf2292bb2e4b058efdfe0b2ba78569872e1dbda110b9b7b29c4948a787fb9fde399 SHA512 b2a8f256ea304150477df98f5e6c16c90dbfe42c0bae7eeef9fb25a9de02433a7d8b3bf448926a94df69d6adaeb91e277ebfe7f1a5135d9ac9f9ce2dc9bfd804
+DIST spyder-notebook-0.3.0.tar.gz 3862097 BLAKE2B 12f9edb3b49373419e491ae3f123b8c325dddefe5a55e8bb853d720aba2c28fbde0be50ec1e5f74198fa1e21faee8a7378218b3e7b3e8378c82be5ee3a10b9b8 SHA512 9259ccfcd79b7d86d49eda74182e3f1e66188f644ca7560a8929dd07c1a453f17bb976ab325ed55df879a00cbc4d14d3724909fb49c56cf1bbf9665ad69b9ec5
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.3.0.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.3.0.ebuild
new file mode 100644
index 000000000000..50d2780db169
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.1.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+# Tests do not work inside virtx/emerge for some reason, core dumped
+RESTRICT="test"
+distutils_enable_tests pytest
+
+pytthon_test() {
+ virtx pytest -vv
+}