summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-13 11:07:53 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-13 11:08:33 +0100
commitffd01bf26f6ec548b09c4adbc9d5e0cc9738f238 (patch)
tree8a1569e79b0fe985f11f10a81ced423b849c0790 /dev-python/sphinxcontrib-spelling
parentnet-libs/nodejs-14.15.0: drop ppc keyword (diff)
downloadgentoo-ffd01bf26f6ec548b09c4adbc9d5e0cc9738f238.tar.gz
gentoo-ffd01bf26f6ec548b09c4adbc9d5e0cc9738f238.tar.bz2
gentoo-ffd01bf26f6ec548b09c4adbc9d5e0cc9738f238.zip
dev-python/sphinxcontrib-spelling: Revert "Remove old"
HPPA is slacking on keywording. Reverts: 86843484f2505a6452dbc55f473aa9c302842296 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 2473615d33cb..727d0defdbcb 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,4 @@
+DIST sphinxcontrib-spelling-5.3.0.tar.gz 45665 BLAKE2B c44c8c2621aecd74734c6137e1344a763e99fb61b3ce882c8ea70364df17a7e2fac49acc8878753cab1b70df2cf084de5087bed77f8b1bffe311410ecec3504d SHA512 8f3c4718877e55b0ebcd3d8c0f078a6c06c27c2cdd3cc557fd2e0e990f0c8956179fd9a8b3135b280973e45c0c8657f71372746ef4b55319078db8f16c7e00e9
DIST sphinxcontrib-spelling-5.4.0.tar.gz 46823 BLAKE2B 8303a97b87d953a37db4548d895559baf93969c11f8417aafeb67804ec537f9ea028bcbf6a56eb3290f13871a782dcde142b1927865a6f9eefd5a20dc53061b1 SHA512 7e0fe6289f9482982825a1204c926490a1e31dc85e25e6418ba47f5575430875e3df5f77202ad458044b810bc2a29f989e6bc6f0c9b4934af938716a4ab887f0
DIST sphinxcontrib-spelling-7.0.0.tar.gz 46859 BLAKE2B 08b8fb68f485ce9a091ad889999887c1683c39a99d8b138b1215228a01696181c0c1876004506f54a89812aa96dcb4936145f105829d82017576329bba416f4f SHA512 b5c9585e171747addc2c9d00ede4e4c290286a6f35921fc54bb8a88bb9574b01494e5e7dbf492d59e74afd3c815a2814a4b7d27b3c3aa98a7b6b8934626d2bde
DIST sphinxcontrib-spelling-7.0.1.tar.gz 47435 BLAKE2B c61d6c91f1765cbe793474f22df571fe0dff59caaef68caf48a5e43c211c589cfcdeb4a9cf397568d48071258ad945637db586c5b3c46b0002fb01248b8d4abd SHA512 54e48361554c54c75aa02512cd70759fbbd439947c9a0258e80d377598d4ed63abd7adcff51c898dcfc93c8b2176395d51830cfebd55a81a4fee13740733dea8
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
new file mode 100644
index 000000000000..f253d611a1a7
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+# The doc can only be built from a git repository
+distutils_enable_tests pytest
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}