summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-09 12:29:02 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-09 12:30:19 -0500
commitc08296a602663494d4f5fadf60fcbb8e08414331 (patch)
tree19d46a2dd53a173ed813d38595246f188d9c0331 /dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
parentmedia-sound/ncmpcpp: x86 stable wrt bug #556996 (diff)
downloadgentoo-c08296a602663494d4f5fadf60fcbb8e08414331.tar.gz
gentoo-c08296a602663494d4f5fadf60fcbb8e08414331.tar.bz2
gentoo-c08296a602663494d4f5fadf60fcbb8e08414331.zip
dev-python/sphinxcontrib-newsfeed: add version 0.1.4
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild')
-rw-r--r--dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
new file mode 100644
index 000000000000..5e23f6a6e333
--- /dev/null
+++ b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="News Feed extension for Sphinx"
+HOMEPAGE="http://bitbucket.org/prometheus/sphinxcontrib-newsfeed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demo/. )
+
+ distutils-r1_python_install_all
+}