summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-12 05:35:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-12 05:43:53 +0100
commitde2b3285a7a127c431aad1a074133e12a1f9fc73 (patch)
tree05d121d36032f7334d0aa0c774280eff2596b695 /dev-python/sphinxcontrib-jquery
parentdev-python/asteval: Bump to 0.9.29 (diff)
downloadgentoo-de2b3285a7a127c431aad1a074133e12a1f9fc73.tar.gz
gentoo-de2b3285a7a127c431aad1a074133e12a1f9fc73.tar.bz2
gentoo-de2b3285a7a127c431aad1a074133e12a1f9fc73.zip
dev-python/sphinxcontrib-jquery: New package, v3.0.0
New dependency for dev-python/sphinx_rtd_theme. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-jquery')
-rw-r--r--dev-python/sphinxcontrib-jquery/Manifest1
-rw-r--r--dev-python/sphinxcontrib-jquery/metadata.xml13
-rw-r--r--dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-jquery/Manifest b/dev-python/sphinxcontrib-jquery/Manifest
new file mode 100644
index 000000000000..5dcac46679aa
--- /dev/null
+++ b/dev-python/sphinxcontrib-jquery/Manifest
@@ -0,0 +1 @@
+DIST jquery-3.0.0.gh.tar.gz 121750 BLAKE2B 5b160fa1434b111683824442a0ecb0da230dba7f29161495859845282e1b6471faa256be6fffc2d34c6fc97e4e188bb1247284613bf65bf322fcb77463b6cf83 SHA512 a681f42734f2925b597f8d90c7b90a3f6df9549d1c97195799670542c5eabdc4d4d4aecfef29f56bd74ffad18ab179cc47f27b8395c11388259473690601901a
diff --git a/dev-python/sphinxcontrib-jquery/metadata.xml b/dev-python/sphinxcontrib-jquery/metadata.xml
new file mode 100644
index 000000000000..68f6d58c7f2f
--- /dev/null
+++ b/dev-python/sphinxcontrib-jquery/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">sphinx-contrib/jquery</remote-id>
+ <remote-id type="pypi">sphinxcontrib.jquery</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild b/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
new file mode 100644
index 000000000000..4e923bdc8b5b
--- /dev/null
+++ b/dev-python/sphinxcontrib-jquery/sphinxcontrib-jquery-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=jquery-${PV}
+DESCRIPTION="Extension to include jQuery on newer Sphinx releases"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/jquery/
+ https://pypi.org/project/sphinxcontrib.jquery/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/jquery/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+# MIT for jQuery
+LICENSE="0BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest