summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-21 07:21:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-21 07:28:25 +0200
commitfcb4fd69be482330c6cb2686443eff06a53ccfb8 (patch)
treea02b997f7c23459fb2ae4e89d9698f66d73e1490 /dev-python/sphinx-pytest
parentdev-python/mkdocs-material-extensions: Bump to 1.2 (diff)
downloadgentoo-fcb4fd69be482330c6cb2686443eff06a53ccfb8.tar.gz
gentoo-fcb4fd69be482330c6cb2686443eff06a53ccfb8.tar.bz2
gentoo-fcb4fd69be482330c6cb2686443eff06a53ccfb8.zip
dev-python/sphinx-pytest: Bump to 0.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-pytest')
-rw-r--r--dev-python/sphinx-pytest/Manifest1
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
index c4353293bdc7..4cef5880778a 100644
--- a/dev-python/sphinx-pytest/Manifest
+++ b/dev-python/sphinx-pytest/Manifest
@@ -1 +1,2 @@
DIST sphinx-pytest-0.1.1.gh.tar.gz 6744 BLAKE2B f196a9fff7a63d1b7664f334c01f38fc44f5611be012092dad077f27bb2ddf03f2ebb7ebcbf7132a9b8c8b17166673945e9b92e88f285c4c95c4c2a696285cbc SHA512 f3210f8b2413171cc37a38fc66b8be0cd32db1a0aebb979dc9057a861711481fde6b86b7c9548166f906d9483762b864759fb4f7ba5069cda4d9fc12c1e2975c
+DIST sphinx-pytest-0.2.0.gh.tar.gz 6935 BLAKE2B a18755669865512ee5ecec46abebf654705efb64165306126144af9df056a829efc5c818abad2477e86edb3da2cb1bf4aadc4e8807cf3c289e29fffa249bbfbf SHA512 dfcbe36c74bf01ff45895893faa11a643b667d277e5f5011978c5cd1404f79d614c6603cf8756ef3e5fec278ea01c6e289cb825725e4e218f75a7bcb12e11bbb
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild
new file mode 100644
index 000000000000..5cf11f8e357d
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/sphinx-extensions2/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/sphinx-extensions2/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest