summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-21 10:12:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-21 11:21:07 +0200
commitb8380ae3bcb24cdd1d6d4527d4155a7e6c4a9b4a (patch)
tree6893ca7d6801456ffb765f43c0ef7badff1f8bc2 /dev-python/sphinx-notfound-page
parentdev-python/sphinx: Remove old (diff)
downloadgentoo-b8380ae3bcb24cdd1d6d4527d4155a7e6c4a9b4a.tar.gz
gentoo-b8380ae3bcb24cdd1d6d4527d4155a7e6c4a9b4a.tar.bz2
gentoo-b8380ae3bcb24cdd1d6d4527d4155a7e6c4a9b4a.zip
dev-python/sphinx-notfound-page: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest1
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.7.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 4cd3cee78612..cc4d0a9ed9d5 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1 +1,2 @@
DIST sphinx-notfound-page-0.5.tar.gz 47806 BLAKE2B 4715bed7509970f9198a0c666a568ca403157ad0704d0e1d17d222e6e8dc7adefab3922a4b79e056d20034463d5f034cba8c7b65248569a46866a964abec7e70 SHA512 a48cf4bcc755687c9e02482727ab2c28abe314118cef775e6b5625e2db67e4040745740c3c9fd88206bf050f1621ef20ffb0262ec614c11497ef030f9fb675a3
+DIST sphinx-notfound-page-0.7.1.gh.tar.gz 50670 BLAKE2B b438413585fce3623451015d873242de3e6d7c466aa06b0b6398d7e337d2a0d3c2041973b1f1c8491b1f382d8e87a2da00b6a97e3a857b60cb345e715d2aa27b SHA512 f2894b19f8ccee22ac7f6e3a34f8270923e8cc4b2182d490e6ec46477460555de9b67b0075f74cc089b0b9e7474c6db9373d107d272d161d98a3c5609edfa7a0
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.7.1.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.7.1.ebuild
new file mode 100644
index 000000000000..200e4e029d1b
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+# PyPI tarballs lack tests
+# https://github.com/readthedocs/sphinx-notfound-page/pull/110
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest