summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-18 08:18:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-18 08:33:49 +0100
commit032e1128722046931420dc310a4a233f8a42456b (patch)
tree939bdb3f5db831de64b5aebc16c602439e0a7a31 /dev-python/sphinx-autodoc-typehints
parentdev-python/spyder-kernels: Bump to 2.4.2 (diff)
downloadgentoo-032e1128722046931420dc310a4a233f8a42456b.tar.gz
gentoo-032e1128722046931420dc310a4a233f8a42456b.tar.bz2
gentoo-032e1128722046931420dc310a4a233f8a42456b.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.21.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.21.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index c031084284cd..b53b76c5b1d4 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -4,3 +4,4 @@ DIST sphinx-autodoc-typehints-1.20.1.gh.tar.gz 28374 BLAKE2B 87891c5ee6b1fa76b12
DIST sphinx-autodoc-typehints-1.20.2.gh.tar.gz 28393 BLAKE2B 1ca6ab1e49d57b49d8fc1bfa73cc6e9eccdbb3c1eff6edaea5dd3253c729f7553659b97bc96ae88d5151ba8da87c0c4f225fac471e13995bd5596554ec4423a5 SHA512 0a17586e83567e51fbc9c96383d3f81a4ab6ebb0ec6e6471b00f7e0d70454e11f21f49d58e46e683c48688540de96627cff7496ccf16d130d2a9c7466c8a5193
DIST sphinx-autodoc-typehints-1.21.0.gh.tar.gz 29465 BLAKE2B 64d13fbc720d3415448fe9983c8e5e5aa668df819717528b5a3b11147c285b44530f47754ff0d42d5b3c44a9fdf92d18614de698b40de4a5c4c9fd5995466e9e SHA512 8cba898f5ec07243718e37b6ff04e45d27ec73037dbb58ab8b2db0d1ba062e4208b4b1f9c053c0fe4b591a939ce44dd323f1e83ea01655c9ededd6a24be8aac3
DIST sphinx-autodoc-typehints-1.21.1.gh.tar.gz 29643 BLAKE2B 59d7bbbb0ac94a93ca8be4fded034c89516d3271c096dbb7875966958c7a48c3d838f50bf03786b7ca8ea326b1566c991b559be7a6d37bdbb58946a89c1927f7 SHA512 29deee5960f40e55706a36af9e0a9d92c2eec9d2485c1b1fafef7efa8c86ffa3ccd910a836f25705f5e4d7f79291dcf5f4b3169799986155d20d4829ee7deda0
+DIST sphinx-autodoc-typehints-1.21.3.gh.tar.gz 31362 BLAKE2B 75e32afd0d9969af5fb9bba0febb456e8c2147b6cca83e9d4737645d48408d3c5e92a482b0df1a73d8f2d9825eb9f1bcc71de9b20800447a97a1e61c88adcfff SHA512 dfd54c3c4d41a8eb6e4080a8132bc437d9ac1ab202c61938c1761ab2d2d64069f793ceb0d89ebcbc9b8dcfc425d14779ee9422c2179610731bb8f84c361401dd
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.21.3.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.21.3.ebuild
new file mode 100644
index 000000000000..395c86133d9e
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.21.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}