summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-17 07:25:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-17 07:26:18 +0200
commit01071cdf1d226870697e57c49dd2e9c644ad7417 (patch)
treee247bdd855eb449be30d5c3f8ae385cbf02ba519 /dev-python/soupsieve
parentdev-python/rapidfuzz: Ensure we don't use bundled deps (diff)
downloadgentoo-01071cdf1d226870697e57c49dd2e9c644ad7417.tar.gz
gentoo-01071cdf1d226870697e57c49dd2e9c644ad7417.tar.bz2
gentoo-01071cdf1d226870697e57c49dd2e9c644ad7417.zip
dev-python/soupsieve: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/soupsieve')
-rw-r--r--dev-python/soupsieve/Manifest1
-rw-r--r--dev-python/soupsieve/soupsieve-2.4.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/soupsieve/Manifest b/dev-python/soupsieve/Manifest
index 152568314091..39fc5df20e75 100644
--- a/dev-python/soupsieve/Manifest
+++ b/dev-python/soupsieve/Manifest
@@ -1 +1,2 @@
+DIST soupsieve-2.4.1.gh.tar.gz 105158 BLAKE2B 73ae01835ac7edf17bd1be1eb33cae5d06a7ef21c63fac50d61fd0f3246f734cd76f70245da19334d65746cf6e02a5a4c970ba2fbfb1a79de7fcda0bca1a38de SHA512 71ed91beabd9afef5756dddbb259f2607ca5109b8ff3f0a25bc3d4730f2948e160c20334b1c6e9f9095362f2b9e601e1ccfee09854e000b2f9f83af514790caa
DIST soupsieve-2.4.gh.tar.gz 104437 BLAKE2B cca6185980473245e2c08181142f497584ae01928b4a8569f9436d30df339b93b92c33818dab93b6646f6e1dbeb52242822fffa193be87c18a25324cc03b9e1a SHA512 68885307d8e6731d47372af5130f2fb88567c7d5b5995c84fb11116007b2360dea88aac1b5c8cadc41f99ef71704c4fe710c45318be0be727ed9145ce009e4fd
diff --git a/dev-python/soupsieve/soupsieve-2.4.1.ebuild b/dev-python/soupsieve/soupsieve-2.4.1.ebuild
new file mode 100644
index 000000000000..97f0a6c4a683
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-2.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="
+ https://github.com/facelessuser/soupsieve/
+ https://pypi.org/project/soupsieve/
+"
+SRC_URI="
+ https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest