summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-05-03 22:42:21 +0200
committerZac Medico <zmedico@gentoo.org>2020-05-03 14:23:32 -0700
commit18d0d0d945658538db2688609d167c9ea4cd67c5 (patch)
treec45edb16357c179914305c77b9203b6292333a9d /dev-python/socketio-client/socketio-client-0.7.2.ebuild
parentsys-fs/squashfs-tools-ng: Drop old versions (diff)
downloadgentoo-18d0d0d945658538db2688609d167c9ea4cd67c5.tar.gz
gentoo-18d0d0d945658538db2688609d167c9ea4cd67c5.tar.bz2
gentoo-18d0d0d945658538db2688609d167c9ea4cd67c5.zip
dev-python/socketio-client: Version bump to 0.7.2
Adds py3.7 and py3.8 support, switching to EAPI 7 Closes: https://bugs.gentoo.org/719556 Closes: https://github.com/gentoo/gentoo/pull/15635 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/socketio-client/socketio-client-0.7.2.ebuild')
-rw-r--r--dev-python/socketio-client/socketio-client-0.7.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/socketio-client/socketio-client-0.7.2.ebuild b/dev-python/socketio-client/socketio-client-0.7.2.ebuild
new file mode 100644
index 000000000000..bf5234946351
--- /dev/null
+++ b/dev-python/socketio-client/socketio-client-0.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="socketIO-client"
+DESCRIPTION="A socket.io client library for Python"
+HOMEPAGE="https://github.com/invisibleroads/socketIO-client/ https://pypi.org/project/socketIO-client/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ # https://github.com/invisibleroads/socketIO-client/issues/90
+ # This runs the suite but has nill output to the screen
+ # The bug filed will hopefully yield a more conventional testsuite
+
+ # The import of SocketIO need be made with abs path to run the tests
+ sed -e 's:from .. import:from socketIO_client import:' \
+ -i socketIO_client/tests/__init__.py || die
+ sed -e 's:from ..exceptions import:from socketIO_client.exceptions import:' \
+ -i socketIO_client/tests/__init__.py || die
+
+ "${PYTHON}" socketIO_client/tests/__init__.py || \
+ die "Tests failed under ${EPYTHON}"
+
+ # Return to original form for final install
+ sed -e 's:from socketIO_client import:from .. import:' \
+ -i socketIO_client/tests/__init__.py || die
+ sed -e 's:from socketIO_client.exceptions import:from ..exceptions import:' \
+ -i socketIO_client/tests/__init__.py || die
+}