summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-15 05:41:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-15 05:47:51 +0200
commite28e93f04d46e94ef6e34b94af1e36aa15b5df7b (patch)
tree020ea3a565419416820713dccb1a4b120aedcf79 /dev-python/simplejson
parentdev-python/importlib-resources: Bump to 6.4.2 (diff)
downloadgentoo-e28e93f04d46e94ef6e34b94af1e36aa15b5df7b.tar.gz
gentoo-e28e93f04d46e94ef6e34b94af1e36aa15b5df7b.tar.bz2
gentoo-e28e93f04d46e94ef6e34b94af1e36aa15b5df7b.zip
dev-python/simplejson: Bump to 3.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.19.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 070b48b4c162..f13407d7470d 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1 +1,2 @@
DIST simplejson-3.19.2.tar.gz 85311 BLAKE2B eecbe77c9612468a0ce52b165be9b4fc4b3d8bcca99621a2723c50fc0c89cdce981421ba71b85535f1c66b48b7178da37f117f9dec8a66cb6f3fe83e3d2d033e SHA512 d92bf617e27b66d93a5d176d38c0c6ae2777728d1e43fdb8054cc9c2b50e3f340079c82dd3ec1af36c8d6380833d16e8eecdc8dd950bba953c195256b44b46c5
+DIST simplejson-3.19.3.tar.gz 85237 BLAKE2B e3c233201c390a1c864670d9a7a81a6aef5334632afbbc303b31dab06709d8a383451e3c7500be3166282b322b93f4fedc2633a1519cb2e2eaef7c4472e903a6 SHA512 257c10c4c84201f1d9c4d77e823c4ef393bf7214c8947e4c95bcfe7c09140ff1b974cc5b00a6e659961263380673d3c4b67a1b37f878888ed049f1db0b663c92
diff --git a/dev-python/simplejson/simplejson-3.19.3.ebuild b/dev-python/simplejson/simplejson-3.19.3.ebuild
new file mode 100644
index 000000000000..c61dabcb3d8e
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.19.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="+native-extensions"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
+
+src_configure() {
+ # native-extensions are always disabled on PyPy
+ # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
+ export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
+ use native-extensions && export REQUIRE_SPEEDUPS=1
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}