summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-17 06:45:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-17 07:10:24 +0100
commitd20e5e4f7e114789d7e8ddaeb9835dcb52ccb48a (patch)
tree2203d3123a906390cd788c5dbc614a712e98aea0 /dev-python/shapely/shapely-2.0.3.ebuild
parentdev-python/Faker: Bump to 23.2.1 (diff)
downloadgentoo-d20e5e4f7e114789d7e8ddaeb9835dcb52ccb48a.tar.gz
gentoo-d20e5e4f7e114789d7e8ddaeb9835dcb52ccb48a.tar.bz2
gentoo-d20e5e4f7e114789d7e8ddaeb9835dcb52ccb48a.zip
dev-python/shapely: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shapely/shapely-2.0.3.ebuild')
-rw-r--r--dev-python/shapely/shapely-2.0.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/shapely/shapely-2.0.3.ebuild b/dev-python/shapely/shapely-2.0.3.ebuild
new file mode 100644
index 000000000000..30e3436f91d3
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-c99.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf shapely || die
+ epytest --pyargs shapely
+}