summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-26 11:27:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-26 12:17:05 +0200
commitfcebdc1464fc9167ebc0ac7123fe6035de0f050b (patch)
treee8224ae2e8e86580f3abb58703f7c17a38266e91 /dev-python/serverfiles
parentpackage.mask: Last rite dev-python/sdnotify (diff)
downloadgentoo-fcebdc1464fc9167ebc0ac7123fe6035de0f050b.tar.gz
gentoo-fcebdc1464fc9167ebc0ac7123fe6035de0f050b.tar.bz2
gentoo-fcebdc1464fc9167ebc0ac7123fe6035de0f050b.zip
dev-python/serverfiles: Enable py3.{7,8}, modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/serverfiles')
-rw-r--r--dev-python/serverfiles/serverfiles-0.2.1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-python/serverfiles/serverfiles-0.2.1.ebuild b/dev-python/serverfiles/serverfiles-0.2.1.ebuild
index 6fc585fcc3a0..bfb83aa8637e 100644
--- a/dev-python/serverfiles/serverfiles-0.2.1.ebuild
+++ b/dev-python/serverfiles/serverfiles-0.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6)
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
@@ -13,15 +13,10 @@ SRC_URI="https://github.com/biolab/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
+DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest