summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/selenium
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest3
-rw-r--r--dev-python/selenium/metadata.xml9
-rw-r--r--dev-python/selenium/selenium-2.42.1.ebuild22
-rw-r--r--dev-python/selenium/selenium-2.45.0.ebuild24
-rw-r--r--dev-python/selenium/selenium-2.46.0.ebuild24
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
new file mode 100644
index 000000000000..8b6505131f1f
--- /dev/null
+++ b/dev-python/selenium/Manifest
@@ -0,0 +1,3 @@
+DIST selenium-2.42.1.tar.gz 2512942 SHA256 96ea31c628f1d908572422c7caba074efba86422005a6d43fd55428d20f960c6 SHA512 78278ea33058527ee402ffab3c101d70df2608549753a935ba940e09ca7fb6d2a725a74984475aa1fb297ab88ad38c2358f8ae02fc247a6db31c6ec5cdff6651 WHIRLPOOL e0ff9572a333af9f72fc4f16885d957b022a6f80d2f11a5039292b591405e66a2da314f98171b4e895cd819eb785f40f9f4f509982c083d7383a675e0365aaa0
+DIST selenium-2.45.0.tar.gz 2622200 SHA256 72394ce72928c87d36501a75fcc535737d16654fefd6c216c315158294bcc126 SHA512 c9943ebf9a4b00ebe2bb68514936444e864849e721a016e924cde08dc28883782de8415ae6524b3cdac240ca547298c113ede646fc1645f3f1e9ead893d21490 WHIRLPOOL eb24294a3860bc599b4126f8bf64ad4a0bdaeac534443386732a2932d232ae12107e2e041cb60961a80ed804e74dcf27359aca3b7594a588c889c1e984ec1d94
+DIST selenium-2.46.0.tar.gz 2621186 SHA256 fffce2696f1dfd64662086aac276e657e33953b32e265e34c4d28f5f1787e62c SHA512 58d2bbc2768ccee7c238ed64c0e73d6e56977581ebda5d71a58dfd262e6b724501b49cac11a56fc79b700810ac8f7e09d968f4135f6aed4abf8147eecdce99ea WHIRLPOOL fb537963360abf0950ee71fff2a6db889800692434f4b98412d52249054cbbf177c8e4bdf19ab1640a825f7bee072af2c4a9fcf8dfc9f9c365de4639bf69c063
diff --git a/dev-python/selenium/metadata.xml b/dev-python/selenium/metadata.xml
new file mode 100644
index 000000000000..db4d8b6b09ac
--- /dev/null
+++ b/dev-python/selenium/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">selenium</remote-id>
+ <remote-id type="github">SeleniumHQ/selenium</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/selenium/selenium-2.42.1.ebuild b/dev-python/selenium/selenium-2.42.1.ebuild
new file mode 100644
index 000000000000..f4a0a93a3e34
--- /dev/null
+++ b/dev-python/selenium/selenium-2.42.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
+HOMEPAGE="http://pypi.python.org/pypi/selenium/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 arm x86"
+IUSE="doc"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( py/CHANGES py/README )
+DISTUTILS_IN_SOURCE_BUILD=1
+QA_PREBUILT="/usr/lib*/python*/site-packages/${PN}/webdriver/firefox/*/x_ignore_nofocus.so"
diff --git a/dev-python/selenium/selenium-2.45.0.ebuild b/dev-python/selenium/selenium-2.45.0.ebuild
new file mode 100644
index 000000000000..de354a923e94
--- /dev/null
+++ b/dev-python/selenium/selenium-2.45.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
+HOMEPAGE="http://pypi.python.org/pypi/selenium/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( py/CHANGES py/README )
+DISTUTILS_IN_SOURCE_BUILD=1
+QA_PREBUILT="/usr/lib*/python*/site-packages/${PN}/webdriver/firefox/*/x_ignore_nofocus.so"
diff --git a/dev-python/selenium/selenium-2.46.0.ebuild b/dev-python/selenium/selenium-2.46.0.ebuild
new file mode 100644
index 000000000000..d7d0e52d74ac
--- /dev/null
+++ b/dev-python/selenium/selenium-2.46.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python language binding for Selenium Remote Control (version 1.0 and 2.0)"
+HOMEPAGE="http://pypi.python.org/pypi/selenium/ https://github.com/SeleniumHQ/selenium http://www.seleniumhq.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( py/CHANGES py/README )
+DISTUTILS_IN_SOURCE_BUILD=1
+QA_PREBUILT="/usr/lib*/python*/site-packages/${PN}/webdriver/firefox/*/x_ignore_nofocus.so"