summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-06 06:19:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-06 06:26:41 +0200
commitb7a6a76306708a3333c6c5fd05031bc58be40295 (patch)
tree362ec1a466c0b157133259ab22e5c45332868c2c /dev-python/ruamel-yaml
parentapp-admin/awscli: Bump to 1.27.129 (diff)
downloadgentoo-b7a6a76306708a3333c6c5fd05031bc58be40295.tar.gz
gentoo-b7a6a76306708a3333c6c5fd05031bc58be40295.tar.bz2
gentoo-b7a6a76306708a3333c6c5fd05031bc58be40295.zip
dev-python/ruamel-yaml: Bump to 0.17.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.23.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 33c5e7a8ac30..0b01c21a9960 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,2 +1,3 @@
DIST ruamel.yaml-0.17.21.tar.xz 184612 BLAKE2B cc7e2a336d3c77a9f2d7e5d7233ceb4d15fddca3a97ec0e54427469fd24c7c63fc70b258adbad92a816d99a1f9839d41eccb9f3224e7a23884914755fa424bc9 SHA512 87f4723bfc76b1b21168852aabe4b49921f175294ac05b4e3f292f2bcf23fe6595df3e066843d193f881b274be2a7b358bd04625afef913bb0e5811efe98b761
DIST ruamel.yaml-0.17.22.tar.xz 185000 BLAKE2B dda8163bfa52b29801d115bc64ef52c35086f186b4795df9dfcd785584e2de338ca055dbf07f3eaac548b14d338ac89bbda4e95196fd113a8fda3ecacb30bc61 SHA512 ac1af1c829c0a5dc65a66926d03b50eede405c9dafd811eae1b9567c81b6bb86b7dd91f4b7c6bf84d7c4833f8b17860dcfddaf7992241ac6673d7ffecf15466f
+DIST ruamel.yaml-0.17.23.tar.xz 185900 BLAKE2B ff283c979474f14e2f0231d64d0a609f262c4b87764eedb2b6060a66a09388670514f341809e6c5f36b0fbe15412209dbd5da9fc31fd8bda83a4d857beade48e SHA512 1a9c22357d61e31464cdead9d0c7715f156839861b8d93b94fa78f00b8d75e803d5bd74fc7d36e1d20f5927f807c3a9ed6af79746177a1d5da0622729597807e
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.23.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.23.ebuild
new file mode 100644
index 000000000000..255ffe55c09d
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.23.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}