summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-16 17:28:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-16 17:28:45 +0100
commitcdcb4e098554ca2627390142c0d707e7c44eb446 (patch)
tree56550a53fbc225653ceab476de38780d137209b3 /dev-python/rpyc
parentsys-kernel/gentoo-kernel-bin: Bump to 6.0.9 (diff)
downloadgentoo-cdcb4e098554ca2627390142c0d707e7c44eb446.tar.gz
gentoo-cdcb4e098554ca2627390142c0d707e7c44eb446.tar.bz2
gentoo-cdcb4e098554ca2627390142c0d707e7c44eb446.zip
dev-python/rpyc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest1
-rw-r--r--dev-python/rpyc/rpyc-5.1.0.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 454ef371ecf7..92b21b8e61f8 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,2 +1 @@
-DIST rpyc-5.1.0.tar.gz 1260651 BLAKE2B 4be17e5de4b0475cd63b99bf20e55e3221149f974b9efec638e0387d71815a5a2e4ea782578152690e019e7b8a4ece17405eed6626578a9c9e379d0f4b589008 SHA512 e9783392f423abca6b488dff5be36dae066980004bd221ca5a1c451f0f9dc7e1daf749650106802f9159de619a8d5e2cd6dc90e9a5f49d16f01bbedd59b504cf
DIST rpyc-5.2.3.tar.gz 1267934 BLAKE2B 3c03d587293375f875de31d6a89ba07b47bd4f4ff9fd5c7b23ed0c83e420e9d2bab08844c3538299797203ac90e7e81b955db02de70bf1cee5ea59d8475a6848 SHA512 4be189a719be100886e08d9c2c0769d12b7d1c5e167c197ebee1a3db542e228f2124fea976e5af3680136b298ce4632c79b2f302128dff31ebf45dcf52a9743f
diff --git a/dev-python/rpyc/rpyc-5.1.0.ebuild b/dev-python/rpyc/rpyc-5.1.0.ebuild
deleted file mode 100644
index 1cbb2a594a61..000000000000
--- a/dev-python/rpyc/rpyc-5.1.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
-HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
- https://pypi.org/project/rpyc/
- https://github.com/tomerfiliba-org/rpyc"
-SRC_URI="https://github.com/tomerfiliba-org/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# USE flags gdb, numpy are used *only* to run tests depending on these packages
-IUSE="test numpy gdb"
-RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
- gdb? ( sys-devel/gdb )"
-
-RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]"
-
-src_prepare() {
- default
-
- # Windows specific test
- rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
-
- # These tests require running sshd
- rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
-
- # This test requires internet access
- rm tests/test_registry.py || die "rm test_registry.py failed"
-
- # This test fails with NO_CIPHERS_AVAILABLE
- rm tests/test_ssl.py || die "rm test_ssl.py failed"
-
- if ! use numpy
- then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
- fi
-
- if ! use gdb
- then rm tests/test_gdb.py || die "rm test_gdb.py failed"
- fi
-}
-
-python_test() {
- # for some reason, when tests are run via pytest or nose, some of them hung
- pushd tests > /dev/null || die "pushd tests failed"
- for x in test_*.py
- do ${PYTHON} ${x} || die "${x} failed"
- done
- popd > /dev/null
-}