summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-05-17 18:24:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-05-17 18:28:35 +0200
commit77d95502335089c1cc47a74bad83a15459392f0c (patch)
treef5f41ae918441e8cdc7352bf8f291facc62fc48b /dev-python/rospkg
parentnet-analyzer/hydra: Version 9.0 (diff)
downloadgentoo-77d95502335089c1cc47a74bad83a15459392f0c.tar.gz
gentoo-77d95502335089c1cc47a74bad83a15459392f0c.tar.bz2
gentoo-77d95502335089c1cc47a74bad83a15459392f0c.zip
dev-python/rospkg: bump to 1.1.9
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.1.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index 55489bb818ee..58486c8e49e7 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1,2 +1,3 @@
DIST rospkg-1.1.4.tar.gz 89554 BLAKE2B b307482cc3df0f2a178dd427a37160cfdc3c407b2135a28854f3df0ff964ed57c17a8ee358a1aa90b3d735e0913bc6c3c8ea1084efdef5fd01933166e21ebac8 SHA512 1758dcbe28c18c834a60bbda2e5e6be34629b3dd4f6519f24dfa1324ff9fc59fb7d0ae9d324c002eee06ff672309627e48f97119b36601390b24a24ae196d5c5
DIST rospkg-1.1.7.tar.gz 90200 BLAKE2B 5b64be62b292ed8d216058d9e906451c74ebfecced92da2888b6e6340a217f56460b9dad6fb741a1b78c156513adfb435407dfac19a9fcbca49b180662b879a2 SHA512 7d6915a32370786384220cd0d62087e0f82648e96f2006853dfb1486ff5b6c3343e32b9ac8a33ad1c1a8c758499475553b081166ca7ee0c72659855a2b09f151
+DIST rospkg-1.1.9.tar.gz 90412 BLAKE2B 4cca7d1ebfcba495aafd766f0d720a6bc6e5aade0bff098d4a1cbab3b55c7a720de7d1f97edf806a93cc21eeda4cac86e844b5e3b23f85cbcb7b328fd07da222 SHA512 d33005e29313ba06959189f8f563361fd9523c2368855f260347b4c509d8b4053f74db3e2cf5986031653d647ded097f272f65d617da93e13cf77a906cb56ca6
diff --git a/dev-python/rospkg/rospkg-1.1.9.ebuild b/dev-python/rospkg/rospkg-1.1.9.ebuild
new file mode 100644
index 000000000000..0e81f9b79bb0
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}