summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 09:23:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:50 +0100
commit8048f896547b86cc76dfc0dd2e757eabe41b7ebd (patch)
treef89463adefa58d98e6f527bce4a653c32ff9abe3 /dev-python/rosdistro
parentdev-ros/cmake_modules: Bump to 0.4.1 (diff)
downloadgentoo-8048f896547b86cc76dfc0dd2e757eabe41b7ebd.tar.gz
gentoo-8048f896547b86cc76dfc0dd2e757eabe41b7ebd.tar.bz2
gentoo-8048f896547b86cc76dfc0dd2e757eabe41b7ebd.zip
dev-python/rosdistro: Bump to 0.6.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/rosdistro')
-rw-r--r--dev-python/rosdistro/Manifest1
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
index a75247169d03..de82bc732bf6 100644
--- a/dev-python/rosdistro/Manifest
+++ b/dev-python/rosdistro/Manifest
@@ -1,2 +1,3 @@
DIST rosdistro-0.4.7.tar.gz 42265 SHA256 7b98e5c82ce81bd8080f159a7c907bca8bf77f6cb4bae8a3265f44e3d73b838f SHA512 adc841b19ad247f44d52cb819851715c94a73fc99ac175c0ee5656f69b86f7630a84259a9c96fa20a687ad32fa9e8e9f77802ae7b70700e53c87ee938bac2cac WHIRLPOOL 85d36fae44f895176a2ef151129baa86a9eef53700496dda2129d74d40fe67f0dbd4109df0ac7c534db1b3c712eafa73bcf3deabdd3f2dda3b5777d96a70ea69
DIST rosdistro-0.5.0.tar.gz 48017 SHA256 dbf98013051b8ebd0e940828bb4a66c0d6fc1ec3ef36467f44636ee86d0422bf SHA512 e5a64442c56c7b60d1f334e42896172ccd07b87fbf9b5f877528073069ce63939482a5257e5dab8c16be633c044a744419017953b5dec4d9664221cf841776a8 WHIRLPOOL 4a5165340c9bcc8c46f72e70998886ec43c94a15b5c62a6a0af0c030166e369ab769fda03819b084384615cf3ad2d43f89961c73ad8ac9b835e687880b2b0a48
+DIST rosdistro-0.6.1.tar.gz 48699 SHA256 51c9a3a5ff4931310c6c7cf5a23a2c64b2432ed9154a159a9ca3ce55c608600f SHA512 9f7c9eea737da443b1daaacde6bcea163ac2ffc707efb23016fe77c68423ee192e0610b9aa1c8a4b07735d1784e30a509dc78cf256061fcc4de75ed4c4244f75 WHIRLPOOL 3dca25a0cd68efa41e21d71d1528213f9ca54719ea3b1dc3cb8e90b6a932d98d97874d4cf6ef3630f3413a7a15b6004bbba8e3aa72d509d11836d3a6cee79519
diff --git a/dev-python/rosdistro/rosdistro-0.6.1.ebuild b/dev-python/rosdistro/rosdistro-0.6.1.ebuild
new file mode 100644
index 000000000000..6f235cc43c15
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}