summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 15:27:39 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 15:27:39 -0500
commit2f3f705718dbf762ad95ce8b2c2abd6d4b7df57f (patch)
tree87755c0c5e2d91120f671fa184c4cb40f67d70cd /dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
parentdev-python/keystoneauth: 4.2.1 bump (diff)
downloadgentoo-2f3f705718dbf762ad95ce8b2c2abd6d4b7df57f.tar.gz
gentoo-2f3f705718dbf762ad95ce8b2c2abd6d4b7df57f.tar.bz2
gentoo-2f3f705718dbf762ad95ce8b2c2abd6d4b7df57f.zip
dev-python/requestsexceptions: adding py38 and DISTUTILS_USE_SETUPTOOLS
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild')
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
index 5c3d976f6a4b..10c18dd20248 100644
--- a/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
+++ b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -15,7 +16,5 @@ SLOT="0"
KEYWORDS="amd64 ~arm arm64 x86"
IUSE=""
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="${CDEPEND}"
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"