summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-09-09 23:29:11 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-15 10:37:02 +0200
commit13c07615ceacfdf51151d098f2736ac809496c09 (patch)
treeb18353eeecf8bbd5250cd1a3c2f461dd25c8da7b /dev-python/ratelimit
parentsys-block/thin-provisioning-tools: stable 0.7.0 for ia64, bug #619126 (diff)
downloadgentoo-13c07615ceacfdf51151d098f2736ac809496c09.tar.gz
gentoo-13c07615ceacfdf51151d098f2736ac809496c09.tar.bz2
gentoo-13c07615ceacfdf51151d098f2736ac809496c09.zip
dev-python/ratelimit: new ebuild.
ratelimit introduces a method decorator preventing a method from being called more than once within a given time period. It prevents API providers from banning your applications by conforming to set rate limits. Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5675
Diffstat (limited to 'dev-python/ratelimit')
-rw-r--r--dev-python/ratelimit/Manifest1
-rw-r--r--dev-python/ratelimit/metadata.xml20
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild26
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/ratelimit/Manifest b/dev-python/ratelimit/Manifest
new file mode 100644
index 000000000000..71d7bed96044
--- /dev/null
+++ b/dev-python/ratelimit/Manifest
@@ -0,0 +1 @@
+DIST ratelimit-1.4.1.tar.gz 10700 SHA256 2376d02963fe5b37e18d2d2e8d5b950b692c8d6fcd142cd3491ec716db472af5 SHA512 ab8a2cc95b852f91c614ba5a5a677d2b4b99d5f810ec8a11e69d97af58cef1f67457e1cf686a286073c85b39c2ebbeca0a459382e410c9e8eda12cecdda57f02 WHIRLPOOL 33e4e0bcb81ab2e83bddf081e70cec47a44ad3b5dbd058e0348506b49d9209b18761e33bd9843b2dfe1420eff97f3efbdbd063fec1599a4ab047bbac10df0714
diff --git a/dev-python/ratelimit/metadata.xml b/dev-python/ratelimit/metadata.xml
new file mode 100644
index 000000000000..b656231c3c9c
--- /dev/null
+++ b/dev-python/ratelimit/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ ratelimit introduces a method decorator preventing a method from being
+ called more than once within a given time period. It prevents API providers
+ from banning your applications by conforming to set rate limits.
+ </longdescription>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tomasbasham/ratelimit"</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
new file mode 100644
index 000000000000..a4443b346393
--- /dev/null
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An API rate limit decorator for Python"
+SRC_URI="https://github.com/tomasbasham/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/tomasbasham/ratelimit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test || die
+}