summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2020-03-26 19:37:08 +0100
committerDavide Pesavento <pesa@gentoo.org>2020-03-26 19:37:08 +0100
commit10b422cd8a2aed30665d06c71bc773ce69e31c41 (patch)
tree11d6d2925ea79febf3eb53d38dcefe069be9d1ad /dev-python/qscintilla-python
parentmail-filter/imapfilter: security cleanup (bug #699032) (diff)
downloadgentoo-10b422cd8a2aed30665d06c71bc773ce69e31c41.tar.gz
gentoo-10b422cd8a2aed30665d06c71bc773ce69e31c41.tar.bz2
gentoo-10b422cd8a2aed30665d06c71bc773ce69e31c41.zip
dev-python/qscintilla-python: drop 2.11.3
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest1
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.11.3.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index fbcc8117a9de..384eaefb3f36 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,2 +1 @@
-DIST QScintilla-2.11.3.tar.gz 3006383 BLAKE2B 6238aaff44d6136a64e8c38e38c4886357eb72aa4067f54eda1e876040c41ebce8577e244b81a062e9020c4d142439f5612ca88055d0ba87172ff5b8893938d7 SHA512 83406ef2f425c6288fcac52b01417853186ba860e33e14b236801271e034c327cbb00817cb7247e98bafc1844aeff9f24ec4878ac8ec4bd52d0d2d9778f6b884
DIST QScintilla-2.11.4.tar.gz 3007719 BLAKE2B b0f88a15a3636a0056d3bdac6e5d5bb05a065461c7de7fe0d5ad1740e87ca78a47bc1fd1af90a8751b553e8e326c830088a4cb38c9ebcad6be8bf9ebdb49bad0 SHA512 90fc2427121ca9ae55e34cf636460099bbdadd844318d9ef05f86790a36e25fb64528264bb7bb99e46b7add96378eff0cc69bb692940c6a1bddfadf86a9abdbd
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.11.3.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.11.3.ebuild
deleted file mode 100644
index 0b538885a2bd..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.11.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-inherit python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for QScintilla"
-HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-
-MY_PN=QScintilla
-MY_P=${MY_PN}-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="debug"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/PyQt5-5.12[gui,printsupport,widgets,${PYTHON_USEDEP}]
- >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- ~x11-libs/qscintilla-${PV}:=
-"
-DEPEND="${RDEPEND}
- >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --pyqt=PyQt5
- --qmake="$(qt5_get_bindir)"/qmake
- $(usex debug '--debug --trace' '')
- --verbose
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Fix parallel install failure
- sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
- ${MY_PN}.pro || die
-
- # Run eqmake to respect toolchain and build flags
- eqmake5 -recursive ${MY_PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-}