summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-11 11:12:26 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-11 11:12:31 +0100
commit9e276c984be1309437d2356c63752ac96d14bb57 (patch)
tree127bcc3cfa661599b993639415d7a2b3b8e2074d /dev-python/qrcode
parentapp-officeext/ooofbtools: x86 stable wrt bug #565438 (diff)
downloadgentoo-9e276c984be1309437d2356c63752ac96d14bb57.tar.gz
gentoo-9e276c984be1309437d2356c63752ac96d14bb57.tar.bz2
gentoo-9e276c984be1309437d2356c63752ac96d14bb57.zip
dev-python/qrcode: Use optfeature to point to optional deps
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=500742 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/qrcode')
-rw-r--r--dev-python/qrcode/qrcode-5.0.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/qrcode/qrcode-5.0.1.ebuild b/dev-python/qrcode/qrcode-5.0.1.ebuild
index 85829571ffea..17cfdabe4b83 100644
--- a/dev-python/qrcode/qrcode-5.0.1.ebuild
+++ b/dev-python/qrcode/qrcode-5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="QR Code generator on top of PIL"
HOMEPAGE="https://pypi.python.org/pypi/qrcode"
@@ -17,9 +17,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-# optional deps:
-# - dev-python/lxml for svg backend
-# - virtual/pil for PIL backend
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -28,3 +25,8 @@ DEPEND="${RDEPEND}
python_test() {
"${PYTHON}" -m unittest qrcode.tests || die "Testing failed with ${EPYTHON}"
}
+
+pkg_postist() {
+ optfeature "svg backend" dev-python/lxml
+ optfeature "PIL backend" dev-python/pillow
+}