summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-25 19:27:14 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-25 19:35:43 -0800
commit2294f62841656970a6a9164115df73fc41cd279a (patch)
treebbdb3c1f9a17bb6ea5d6e6a835c6e01e179be8e6 /dev-python/pyzmq
parentsys-libs/musl: Version bump 1.2.0 (diff)
downloadgentoo-2294f62841656970a6a9164115df73fc41cd279a.tar.gz
gentoo-2294f62841656970a6a9164115df73fc41cd279a.tar.bz2
gentoo-2294f62841656970a6a9164115df73fc41cd279a.zip
Revert dev-python/pyzmq py2 and net-wireless/urh update
This commit reverts a revert of python2 support removal for dev-python/pyzmq. The original commit that remove py2 support was 3635fb573254 (dev-python/pyzmq: Remove py2), committed January 28th. Since then presumably a large number of dependencies of pyzmq have also dropped python2 support, because after commit c3bb20728e45 (Revert "Revert "dev-python/pyzmq: Remove py2"") from February 25 pkgcheck scan says: NonsolvableDepsInStable: version 16.0.2: nonsolvable depset(depend) keyword(amd64) stable profile (default/linux/amd64/17.0) (76 total): ... ... NonsolvableDepsInStable: version 17.1.0: nonsolvable depset(depend) keyword(amd64) stable profile (default/linux/amd64/17.0) (57 total): ... So it doesn't appear to be a trivial task to restore py2 support to pyzmq. Unfortunately this will break net-wireless/urh (both in terms of the software and in terms of the deptree). To keep the deptree in good shape commit f1b680936d23 (net-wireless/urh: fix deps, probably) must also be reverted. This reverts commit c3bb20728e45505d9b4a48164f37bb3288577d67. This reverts commit f1b680936d23084dc28bcab64e2cc4103a420303. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/pyzmq-16.0.2.ebuild5
-rw-r--r--dev-python/pyzmq/pyzmq-17.1.0.ebuild5
2 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/pyzmq/pyzmq-16.0.2.ebuild b/dev-python/pyzmq/pyzmq-16.0.2.ebuild
index 914737e0cb2b..c6f982a73c26 100644
--- a/dev-python/pyzmq/pyzmq-16.0.2.ebuild
+++ b/dev-python/pyzmq/pyzmq-16.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,13 +22,11 @@ RDEPEND="
>=net-libs/zeromq-4.1.2:=
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
www-servers/tornado[${PYTHON_USEDEP}]
)
doc? (
@@ -53,7 +51,6 @@ python_compile_all() {
python_compile() {
esetup.py cython --force
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile
}
diff --git a/dev-python/pyzmq/pyzmq-17.1.0.ebuild b/dev-python/pyzmq/pyzmq-17.1.0.ebuild
index 90216948f4ff..e7d8b211d806 100644
--- a/dev-python/pyzmq/pyzmq-17.1.0.ebuild
+++ b/dev-python/pyzmq/pyzmq-17.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,13 +22,11 @@ RDEPEND="
>=net-libs/zeromq-4.2.2-r2:=[drafts]
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
>=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
)
doc? (
@@ -55,7 +53,6 @@ python_compile_all() {
python_compile() {
esetup.py cython --force
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile
}