summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-24 18:02:41 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-24 18:08:58 +0200
commit1cfb464fb47e64a219859329ed65692293cc7197 (patch)
treed4d7984570057d8442d590e563759ef0bd38b3bc /dev-python/pyxattr
parentdev-python/pyxattr: Ignore selinux xattrs by default (diff)
downloadgentoo-1cfb464fb47e64a219859329ed65692293cc7197.tar.gz
gentoo-1cfb464fb47e64a219859329ed65692293cc7197.tar.bz2
gentoo-1cfb464fb47e64a219859329ed65692293cc7197.zip
dev-python/pyxattr: Allow overriding TEST_*
Closes: https://bugs.gentoo.org/503946
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/pyxattr-0.6.0-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/pyxattr/pyxattr-0.6.0-r1.ebuild b/dev-python/pyxattr/pyxattr-0.6.0-r1.ebuild
index 0f47e843d3e3..eab5d45fc294 100644
--- a/dev-python/pyxattr/pyxattr-0.6.0-r1.ebuild
+++ b/dev-python/pyxattr/pyxattr-0.6.0-r1.ebuild
@@ -42,12 +42,20 @@ python_compile_all() {
src_test() {
# Perform the tests in /var/tmp; that location is more likely
# to have xattr support than /tmp which is often tmpfs.
- local -x TEST_DIR=/var/tmp
+ local -x TEST_DIR="${TEST_DIR:-/var/tmp}"
# Ignore selinux attributes by default, bug #503946.
- local -x TEST_IGNORE_XATTRS="security.selinux"
+ local -x TEST_IGNORE_XATTRS="${TEST_IGNORE_XATTRS:-security.selinux}"
- einfo 'Please note that the tests fail if xattrs are not supported'
- einfo 'by the filesystem used for /var/tmp.'
+ einfo "Please note that the tests fail if xattrs are not supported"
+ einfo "by the filesystem used for ${TEST_DIR}."
+ einfo
+ einfo "The location for tests can be overriden using TEST_DIR variable:"
+ einfo " $ export TEST_DIR=/my/test/place"
+ einfo
+ einfo "Additionally, TEST_IGNORE_XATTRS can be set to control which"
+ einfo "external attributes are ignored by the tests."
+ einfo "See https://bugs.gentoo.org/503946 for details."
+ einfo
distutils-r1_src_test
}