summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 11:16:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 11:17:49 +0100
commitd73ab0fde69fbc7f1593f73d8442279137b12bcf (patch)
treea18f5bbe48283ffe5304a39359006180534b1ffa /dev-python/pywayland
parentdev-python/poetry-core: Remove old (diff)
downloadgentoo-d73ab0fde69fbc7f1593f73d8442279137b12bcf.tar.gz
gentoo-d73ab0fde69fbc7f1593f73d8442279137b12bcf.tar.bz2
gentoo-d73ab0fde69fbc7f1593f73d8442279137b12bcf.zip
dev-python/pywayland: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pywayland')
-rw-r--r--dev-python/pywayland/Manifest1
-rw-r--r--dev-python/pywayland/pywayland-0.4.16.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/pywayland/Manifest b/dev-python/pywayland/Manifest
index a4140b4d294c..52f42aeeed4d 100644
--- a/dev-python/pywayland/Manifest
+++ b/dev-python/pywayland/Manifest
@@ -1,2 +1 @@
-DIST pywayland-0.4.16.gh.tar.gz 61058 BLAKE2B 4b299fe1b3067e2e222012db921b4ae5fdfd103b0ca2b796522236b6b8b2ffc1e54ba8c97d30970cb5df35c9da18ca217ea5d97a37b11d7112d93c59a1df164f SHA512 1098e0ae88ffc874d1e49f6441f06db05d1bfebead06d65e1214d69542b9ada0ec45bfccd6fd11dd188b2ebcf3d0ac2a2370927af8a0838f4e683ec50fc5e01a
DIST pywayland-0.4.17.gh.tar.gz 61171 BLAKE2B f190107ab361ec9c0a568d22a104fa06a7e52a348a6226c30c2ae542b77e5b21b4a389ad745efb864b58cff9e77cb22ff43fd6614859cb138d398a84b99614a5 SHA512 9ca1e30b56f6d1447744451d15d84041d5ce6ce64811ca0e395822731f0c7cd1d8571f640b89771d8f5e9da1d82385734974e10e68ccecffc0f9600a83d2478b
diff --git a/dev-python/pywayland/pywayland-0.4.16.ebuild b/dev-python/pywayland/pywayland-0.4.16.ebuild
deleted file mode 100644
index 22002db49b4a..000000000000
--- a/dev-python/pywayland/pywayland-0.4.16.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Python bindings for the libwayland library"
-HOMEPAGE="
- https://pywayland.readthedocs.io/en/latest/
- https://github.com/flacjacket/pywayland
- https://pypi.org/project/pywayland/
-"
-SRC_URI="
- https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-RDEPEND="
- dev-libs/wayland
- $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- ' 'python*')
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/wayland-protocols
-"
-BDEPEND="
- dev-util/wayland-scanner
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Needed for tests (XDG_RUNTIME_DIR)
- xdg_environment_reset
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # No die deliberately as sometimes it doesn't exist
- rm -rf pywayland || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}