summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyvtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyvtk')
-rw-r--r--dev-python/pyvtk/Manifest1
-rw-r--r--dev-python/pyvtk/files/pyvtk-0.4.74.patch20
-rw-r--r--dev-python/pyvtk/metadata.xml8
-rw-r--r--dev-python/pyvtk/pyvtk-0.4.74.ebuild24
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyvtk/Manifest b/dev-python/pyvtk/Manifest
new file mode 100644
index 000000000000..bc953eea26ee
--- /dev/null
+++ b/dev-python/pyvtk/Manifest
@@ -0,0 +1 @@
+DIST PyVTK-0.4.74.tar.gz 25700 SHA256 a34cc4660a85f4828bedf28ff2b4c95baad98fc8f79e2647c59b5ea66c9250c7 SHA512 c3b29dd067339c1708f9757b83a127cbe008b291265181272b69a85c0348bc1388c4914acc24efdefda0421a601eede10af762753e683fbd0518361035313098 WHIRLPOOL 2512351725cbfa744df521b3a4e44179a521a131f3fdcbee78ac6cdbfa7c7c3997a50665b1264d9cd9b9f18e5403854e85eb76c65dea640f1b888da9c66e6b17
diff --git a/dev-python/pyvtk/files/pyvtk-0.4.74.patch b/dev-python/pyvtk/files/pyvtk-0.4.74.patch
new file mode 100644
index 000000000000..651c1f5ec37c
--- /dev/null
+++ b/dev-python/pyvtk/files/pyvtk-0.4.74.patch
@@ -0,0 +1,20 @@
+--- PyVTK-0.4.74/lib/__init__.py 2003-04-07 16:56:08.000000000 +0200
++++ PyVTK-0.4.74/lib/__init__.py 2008-12-03 18:08:35.000000000 +0100
+@@ -202,7 +202,7 @@
+ #print 'Reading file',`filename`
+ f = open(filename,'rb')
+ l = f.readline()
+- if not l.strip().replace(' ','').lower() == '#vtkdatafileversion2.0':
++ if not l.strip()[-3:] == '1.0' and not l.strip()[-3:] == '2.0' and not l.strip()[-3:] == '3.0':
+ raise TypeError, 'File '+`filename`+' is not VTK 2.0 format'
+ self.header = f.readline().rstrip()
+ format = f.readline().strip().lower()
+@@ -222,7 +222,7 @@
+ for i in range(2):
+ if only_structure: break
+ if not l: break
+- l = [s.strip() for s in l.lower().split(' ')]
++ l = [s.strip() for s in l.lower().split()]
+ assert len(l)==2 and l[0] in ['cell_data','point_data'], l[0]
+ data = l[0]
+ n = eval(l[1])
diff --git a/dev-python/pyvtk/metadata.xml b/dev-python/pyvtk/metadata.xml
new file mode 100644
index 000000000000..5ef07a39e7e1
--- /dev/null
+++ b/dev-python/pyvtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyvtk/pyvtk-0.4.74.ebuild b/dev-python/pyvtk/pyvtk-0.4.74.ebuild
new file mode 100644
index 000000000000..965f91cf47e4
--- /dev/null
+++ b/dev-python/pyvtk/pyvtk-0.4.74.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=PyVTK-${PV}
+
+DESCRIPTION="Tools for manipulating VTK files in Python"
+HOMEPAGE="http://cens.ioc.ee/projects/pyvtk/"
+SRC_URI="http://cens.ioc.ee/projects/pyvtk/rel-0.x/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}.patch )