summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyusb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyusb')
-rw-r--r--dev-python/pyusb/Manifest2
-rw-r--r--dev-python/pyusb/metadata.xml12
-rw-r--r--dev-python/pyusb/pyusb-0.4.3.ebuild32
-rw-r--r--dev-python/pyusb/pyusb-1.0.0_beta2.ebuild28
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyusb/Manifest b/dev-python/pyusb/Manifest
new file mode 100644
index 000000000000..2125e5712295
--- /dev/null
+++ b/dev-python/pyusb/Manifest
@@ -0,0 +1,2 @@
+DIST pyusb-0.4.3.tar.gz 16242 SHA256 3c08b292886b7001ab088345af4d0dfe3e7d37bfc4b2bdcd7edb564ea3ef04d5 SHA512 efe90f910cd8b02646de4ec47e28f6debbcc3c4ff7aa0a45d8355840abfdb079f8e9ac9ce78b785e3f5a26772c5118362e9f4a7a3629985eae2063bc06b53e4a WHIRLPOOL 1a7f231520cf7f1a9777fadad5bfa1f4886172f5a643ba6b9dc5a58bf687629629670d8c12b79844ce692010b8bcd25dede5d6182d3677c9c8beea0cad3b9c7f
+DIST pyusb-1.0.0b2.tar.gz 57747 SHA256 14ec66077bdcd6f1aa9e892a0a35a54bb3c1ec56aa740ead64349c18f0186d19 SHA512 8a69f6cb3e2876a52c1caa0854e98586cf6d7e01225b132b4d37b92814727ae66398282aedbe5e521c509dc3ee6dfc5799b9f22890be7c7a387eb427921cd73b WHIRLPOOL 45c70c339490789e2e1195a8b040358380e5e22438e58344e40b42c795a276d6e30c3efc452791ffe4093287c9d01f44d47be25c07fba925c9198c8f630149ba
diff --git a/dev-python/pyusb/metadata.xml b/dev-python/pyusb/metadata.xml
new file mode 100644
index 000000000000..70519d001776
--- /dev/null
+++ b/dev-python/pyusb/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ pyusb is a python wrapper for the libusb user space USB device library.
+ </longdescription>
+ <maintainer><email>josejx@gentoo.org</email><name>Joseph Jezak</name></maintainer>
+ <upstream>
+ <remote-id type="pypi">pyusb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyusb/pyusb-0.4.3.ebuild b/dev-python/pyusb/pyusb-0.4.3.ebuild
new file mode 100644
index 000000000000..a06a5d98f4fb
--- /dev/null
+++ b/dev-python/pyusb/pyusb-0.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils flag-o-matic
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="http://pyusb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+### The bus enumeration does not appear to work with libusb-compat
+### A new version based on libusb-1.x is in the works, but not yet released
+DEPEND="virtual/libusb:0"
+RDEPEND="${DEPEND}"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
diff --git a/dev-python/pyusb/pyusb-1.0.0_beta2.ebuild b/dev-python/pyusb/pyusb-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..7f5b3c1c76de
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.0.0_beta2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_P="${P/_beta/b}"
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="http://pyusb.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS="README.rst docs/tutorial.rst"
+
+S="${WORKDIR}/${MY_P}"