summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-16 21:57:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-16 22:05:09 +0100
commit22c7421e7b948831718b49dcad06c5ff55ecc645 (patch)
treedff8d289072b958c03f0b5f3b17f94de99d11cb4 /dev-python/python-utils
parentdev-libs/flatbuffers: Stabilize 2.0.0-r1 arm64, #829330 (diff)
downloadgentoo-22c7421e7b948831718b49dcad06c5ff55ecc645.tar.gz
gentoo-22c7421e7b948831718b49dcad06c5ff55ecc645.tar.bz2
gentoo-22c7421e7b948831718b49dcad06c5ff55ecc645.zip
dev-python/python-utils: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-2.6.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index e379fe32efa5..d583977eaf8c 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python-utils-2.5.6.tar.gz 14057 BLAKE2B 2f66ab26cd6cda25f73c9f40081048404cde819e3e3c2fd11d134244ab2b80a05ab2b943e56a45bd8656bf3ba231853e3bfa9efbab9cb70515daaec70f6e0715 SHA512 35299880afdecd4a44144b95e6b2073e51680dfd2b00f31fb333d578cfa2c2f8bf5f58128cab88a7b81e658e6d5dca303f1c9f5be3870160679e1defbf94859e
+DIST python-utils-2.6.0.tar.gz 14885 BLAKE2B 089d7a57a8469968bed147a01907f35d1430349130e0f7152bbd38dd65053cf3d6424942eee8cc9006baaec5f13bffcbef81bd8723cad7ee03b1358a5c2d3d27 SHA512 a582558e38342f54f7c1eda1f9038728dd5904729aaec4e5719e56bb447bc6fcb93bf5ea3af134ce245eda059b9be81d15b268165cbc10799ba112fc157f939b
diff --git a/dev-python/python-utils/python-utils-2.6.0.ebuild b/dev-python/python-utils/python-utils-2.6.0.ebuild
new file mode 100644
index 000000000000..ae6983ffe562
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}