summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-social-auth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-social-auth')
-rw-r--r--dev-python/python-social-auth/Manifest2
-rw-r--r--dev-python/python-social-auth/metadata.xml8
-rw-r--r--dev-python/python-social-auth/python-social-auth-0.1.26.ebuild57
-rw-r--r--dev-python/python-social-auth/python-social-auth-0.2.10.ebuild58
4 files changed, 125 insertions, 0 deletions
diff --git a/dev-python/python-social-auth/Manifest b/dev-python/python-social-auth/Manifest
new file mode 100644
index 000000000000..85f7f715f52b
--- /dev/null
+++ b/dev-python/python-social-auth/Manifest
@@ -0,0 +1,2 @@
+DIST python-social-auth-0.1.26.tar.gz 247579 SHA256 9f0a9e8526850e9d0bdd4e5df4d2a6129c4da5a747887ccbfebafc0d2868120c SHA512 c3637f9a269f2c8465b1896840a5ca0f70bb6c45c93f7d9c08c54434037984538ba95442a164841c069cb5b1fd251d0f3f62baa1dc2754a542baceb2f325bd8b WHIRLPOOL e9d17f1c7b094cf0c20d7cee6ba06e0557b322d24aa6bf53743e49eaa08bf8935e71b7d1793227d53d6ff9cacebae975768feab5f6d37d683df8f16caf19a9ed
+DIST python-social-auth-0.2.10.tar.gz 297210 SHA256 10dd7df9e2bb6143cf33170ae53b7463a6947ed111da7158d8e3fd60fafe5d91 SHA512 af5247cee0b77f36d1bfdd7457708c2f2053bc779bae8eae0cfe79f0f9236c37882afcbd325863255282eb7559d8f84715b3e983f94d55bd3e7815c5469f150d WHIRLPOOL 7bbc97885ce4d74785b4506b3ddb133fb9751625193742194ca6cc78e3a76fb8e07c9440bfac7e661fe76363a78b66c87049282163c9923015ce3251da235881
diff --git a/dev-python/python-social-auth/metadata.xml b/dev-python/python-social-auth/metadata.xml
new file mode 100644
index 000000000000..f51439d41095
--- /dev/null
+++ b/dev-python/python-social-auth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">omab/python-social-auth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild b/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild
new file mode 100644
index 000000000000..ab01c01a04fd
--- /dev/null
+++ b/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to setup social auth mechanism with support for several frameworks and auth providers"
+HOMEPAGE="http://psa.matiasaguirre.net/"
+SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="doc examples test"
+
+RDEPEND="
+ $(python_gen_cond_dep \
+ 'dev-python/python-openid[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep \
+ 'dev-python/python3-openid[${PYTHON_USEDEP}]' 'python3*')
+ >=dev-python/oauthlib-0.3.8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ >=dev-python/six-1.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+# tests require internet
+#"
+# test? (
+# dev-python/coverage[${PYTHON_USEDEP}]
+# dev-python/httpretty[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# dev-python/nose[${PYTHON_USEDEP}]
+# dev-python/sure[${PYTHON_USEDEP}]
+# )
+#"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+#python_test() {
+# "${S}"/social/tests/run_tests.sh || die "Tests failed on ${EPYTHON}"
+#}
diff --git a/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild b/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild
new file mode 100644
index 000000000000..716f81f37634
--- /dev/null
+++ b/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to setup social auth mechanism with support for several frameworks and auth providers"
+HOMEPAGE="http://psa.matiasaguirre.net/"
+SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+RDEPEND="
+ $(python_gen_cond_dep \
+ 'dev-python/python-openid[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep \
+ 'dev-python/python3-openid[${PYTHON_USEDEP}]' 'python3*')
+ >=dev-python/oauthlib-0.3.8[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.2.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ >=dev-python/six-1.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+# tests require internet
+#"
+# test? (
+# dev-python/coverage[${PYTHON_USEDEP}]
+# dev-python/httpretty[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# dev-python/nose[${PYTHON_USEDEP}]
+# dev-python/sure[${PYTHON_USEDEP}]
+# )
+#"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+#python_test() {
+# "${S}"/social/tests/run_tests.sh || die "Tests failed on ${EPYTHON}"
+#}