summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-03 22:00:06 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-03 22:39:24 +0200
commit36ee368becbb62e37e9a548e88e6e9390816c650 (patch)
treed91152ef9666d7b3206982a85f901571f49540c4 /dev-python/python-magic
parentdev-python/filetype: add 1.0.10 (diff)
downloadgentoo-36ee368becbb62e37e9a548e88e6e9390816c650.tar.gz
gentoo-36ee368becbb62e37e9a548e88e6e9390816c650.tar.bz2
gentoo-36ee368becbb62e37e9a548e88e6e9390816c650.zip
dev-python/python-magic: add 0.4.25
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-magic')
-rw-r--r--dev-python/python-magic/Manifest1
-rw-r--r--dev-python/python-magic/python-magic-0.4.25.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-magic/Manifest b/dev-python/python-magic/Manifest
index da2f7d689171..4b04d9c265d9 100644
--- a/dev-python/python-magic/Manifest
+++ b/dev-python/python-magic/Manifest
@@ -1 +1,2 @@
DIST python-magic-0.4.24.gh.tar.gz 863700 BLAKE2B 09ecc8bea1696343ec2462e6989da8059c40f88e401390c8c491e531540ef0b38e5a8eac1fb8a3356203e25cf2e5caa6dad0c13d24eb34a7a299b5a071ae29b3 SHA512 b3ec148da398293465299938fabf691b56c4b3876f6abbb7a734a9c0a5180cc758a15f7085bbf1bf40ec6031697ec84d98c161db1fd04301133af09928c611fc
+DIST python-magic-0.4.25.gh.tar.gz 864127 BLAKE2B 84ec440ef1944c7fc23dcbe29156670e0feb48309150c9135fdb1898623fe687aed19c3e9e0ea14f38ef7a8ce070e61f495093056b70da83eda1f862e3957f21 SHA512 5fd8ad8b895e361cad19319d572676c3c7a2a00585fc2272442dc438cb7d272ba518177f15e7846030f692d4391fa4b3d49bc3b36902d195d37316b0feffc8aa
diff --git a/dev-python/python-magic/python-magic-0.4.25.ebuild b/dev-python/python-magic/python-magic-0.4.25.ebuild
new file mode 100644
index 000000000000..4b94bfdc2e76
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.25.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="
+ https://github.com/ahupp/python-magic/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/file[-python]"
+BDEPEND="
+ test? ( sys-apps/file )
+"
+
+python_test() {
+ local -x LC_ALL=en_US.UTF-8
+ "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
+}