summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 09:05:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:11 +0200
commit4c218e7589729be0a60420392423a3fabe5ab1e1 (patch)
treeb1ae2c8a603d07530f163c154e4bb32821009a11 /dev-python/python-engineio
parentdev-python/pytest-flakes: Bump to 4.0.4 (diff)
downloadgentoo-4c218e7589729be0a60420392423a3fabe5ab1e1.tar.gz
gentoo-4c218e7589729be0a60420392423a3fabe5ab1e1.tar.bz2
gentoo-4c218e7589729be0a60420392423a3fabe5ab1e1.zip
dev-python/python-engineio: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 67aa2f6c0969..3f4451e1f1a7 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1 +1,2 @@
DIST python-engineio-4.2.1.gh.tar.gz 297657 BLAKE2B 0a634cec9f71a3b8659e5b07cc326fb3d7801c8a834248d6f2ea5a48bcd058f8d0b86c2e43c110ea18ef641e3ace273a2ebd20f350aec9360d38ffe0f32f2778 SHA512 f0ea7cb0a34f49d2e3de58dc1038f41cda099fba0033af7020b9ccacd34fbf44fd1613ef14d4d05013dd99a2d35330769e6c3d2f532556fd39262229e40714f6
+DIST python-engineio-4.3.0.gh.tar.gz 299122 BLAKE2B 929b16650aaf4a429e9a1353a994cc87022644bef48c59aac9c448ec32533a7a7360413143159809042915f69c4f0ae0c2a13e5fe2d61b729c09890508107948 SHA512 c34688f1dcaf4a1a02dea03d2746b0b0e089387d4ac55024e783ee2dbafb59ac43437138747b63b0710425601b27e1a10c56df7c57c1ed16ab2f812a773c8ec4
diff --git a/dev-python/python-engineio/python-engineio-4.3.0.ebuild b/dev-python/python-engineio/python-engineio-4.3.0.ebuild
new file mode 100644
index 000000000000..3fba6ef7d60a
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest