summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-16 13:09:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-16 13:14:21 +0200
commite27ae239b023d5ec6084146e9220c798af371cb6 (patch)
tree32861223b79b19dbbad89056548ada3b1a8d3edd /dev-python/python-docs
parentdev-python/python-docs: Bump to 3.8.10 (diff)
downloadgentoo-e27ae239b023d5ec6084146e9220c798af371cb6.tar.gz
gentoo-e27ae239b023d5ec6084146e9220c798af371cb6.tar.bz2
gentoo-e27ae239b023d5ec6084146e9220c798af371cb6.zip
dev-python/python-docs: Bump to 3.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.9.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index fb1df0171ca1..03a5f563e3f3 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -4,3 +4,4 @@ DIST python-3.7.10-docs-html.tar.bz2 6289108 BLAKE2B ff751e3b847602f766389a4dc24
DIST python-3.8.10-docs-html.tar.bz2 6604538 BLAKE2B 270c53edc7917926a1fa065b4cd3cf8cb2e1334e55fbe8f7d1b6e52117b44da1e66d1e5ee240055b5f34320aa45145a38636201bd0ffb9751897e5060f987e90 SHA512 74a94ecbcba83f3392f08e36b0697f4213ff9118c68363706d0151c29c50fa12a0e61fd821bb1c16166833872a996e6b53126ba5c9e1c3aa606a57ade5086eb6
DIST python-3.8.8-docs-html.tar.bz2 6590826 BLAKE2B 3d63ed87030ce2a036ada92397bbb7ad5389105702deab5282148ee9ff5d4e93a1d2767e1e9487cff7fecd86fd46e2d7a216bf1578847f7b25f133d6d26ba038 SHA512 1f3da0cb48dd817a31b824ca88b27d8df6bf32d5e6348e339e4b4a06403d5aca37a0984d59d8d954ef037aa427ced77a8163c03887de51bd60ff25a6e5ef2682
DIST python-3.9.2-docs-html.tar.bz2 6818470 BLAKE2B cb2f6cf98e253e2b5e1fafb0c6227e0ac7d12dc603861faa670c5a7ec39990988a289a2ea5f6ceeb49950399a8e5dcc82ecde8c2417e8a55d71c123f54cd3b37 SHA512 bd0d3b39e57fbc897c9fd4fbeec67da7fd71e751b5fc5bb460a21b8d67e5c8d29b7ba38d5b01e9fdf3080a2015d7842022147e92a1322efe3c8ac155b41960d4
+DIST python-3.9.5-docs-html.tar.bz2 6839136 BLAKE2B e05d327c858cb674463b8bbbed53cf92a4816a58275bb493b02c670696cc58c07735685f1e9e1ae39e10bae3c1fb4e253b29e096fcddb5f0a592ac9895fadf36 SHA512 74526fd849f8a8e50e9263f7963e4ef14635c994e8abb89ae6a096703a4a1807316dd1ea095ab33f0fde63f195cb6d94b5e1a523b34d35481441b4fd1d2b5701
diff --git a/dev-python/python-docs/python-docs-3.9.5.ebuild b/dev-python/python-docs/python-docs-3.9.5.ebuild
new file mode 100644
index 000000000000..69cbb66a42be
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.9.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}